Let's encrypt connection is not secure CentOS-6


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: smud8165.info

I ran this command: “./letsencrypt-auto --apache -d smud8165.info -d www.smud8165.info”

It produced this output:
Congratulations! You have successfully enabled https://smud8165.info and
https://www.smud8165.info

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=smud8165.info
https://www.ssllabs.com/ssltest/analyze.html?d=www.smud8165.info

My web server is (include version): Apache 2.2

The operating system my web server runs on is (include version): Cent OS -6

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No, I don’t have control panel


#2

Hi @erronak

you have created one certificate with two domain names:

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:smud8165.info&lu=cert_search

This is good. But you use a self signed certificate.

1. 1. E=root@smud8165.info, CN=smud8165.info, OU=SomeOrganizationalUnit, O=SomeOrganization, L=SomeCity, S=SomeState, C=-- (120) 23.11.2018 23.11.2019
Keyalgorithm RSA encryption (2048 bit)
Signatur: SHA256 With RSA-Encryption
Serial Number: 31BD
Thumbprint: 672BD65FEB1B1A3B9E2D486FED26ED8804AE4DB5
OCSP - Url:
OCSP - must staple: no
Certificate Transparency: no
UntrustedRoot: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.

First try: Reload your Apache. If this doesn’t help, check your certificates with

./letsencrypt-auto certificates

then your configuration to find your correct vHost.


#3

I restarted my services with following commands but didn’t get result.

service named restart;
service httpd restart;

so what I have to do now ?
I am open to show you my configuration files.


#4

Hi,

Could you please check if your DNS server is configtured correctly?

I can’t access your website right now and because the DNS server is not responding…

By the way, could you please share us a screenshot of the issue?

Thank you


#5

Hello ,

I tried this link and it is working for me.