Lets Encrypt challenge failed due to https redirect

I am using ansible 2.9.6 to generate lets encrypt certificate on Jetty. The Jetty is configured for http to https redirect for all request. So when its try for challenge (http://idp.bbsul.edu.pk/.well-known/acme-challenge/uAV06t46JNXYOYJJ4Ma2OAhntiFwUSYzTowQ3Ti0F0g) , the challenge is failed. whereas it is opening on https. is there a way to fixed this? I dont know how to do changes in Jetty.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: idp.bbsul.edu.pk

I ran this command: I am using ansible 2.9.6 script to generate lets encrypt certificate.

It produced this output:
TASK [Complete Let's Encrypt challenges] *****************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Authorization for dns:idp.bbsul.edu.pk returned invalid: CHALLENGE: http-01 DETAILS: Fetching http://idp.bbsul.edu.pk/.well-known/acme-challenge/uAV06t46JNXYOYJJ4Ma2OAhntiFwUSYzTowQ3Ti0F0g: Connection refused;", "other": {}}

My web server is (include version): Jetty 9.4.44.v20210927

The operating system my web server runs on is (include version): ubuntu 20.4

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NO

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

You're diagnosis of the issue is unfortunately incorrect. When I go to your HTTP website, I'm getting a "ERR_CONNECTION_RESET" error. No HTTP to HTTPS redirect. This seems to be unrelated to the challenge, but for your website in general. I.e.: it's down over HTTP.


Many thanks. The issue has been solved.

I think the server was only accepting http connection from , so i disabled this line in start.ini.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.