Lets encrypt certificate not generation MDaemon server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: mail.iob.co.bw

I ran this command:

It produced this output:
Starting Script run at 12/14/2023 11:56:57.
Get the MDaemon paths.
The MDaemon.ini Path is D:\MDaemon\App\MDaemon.ini.
The MDaemon APP Path is D:\MDaemon\App.
The MDaemon Pem path is D:\MDaemon\PEM.
The MDaemon Log path is D:\MDaemon\Logs.
The MDaemon RAW path is D:\MDaemon\Queues\Raw.
The WorldClient Path is D:\MDaemon\WorldClient.
The WorldClient HTML Path is D:\MDaemon\WorldClient\HTML.
The well-known path is D:\MDaemon\WorldClient\HTML.well-known.
The Acme-Challenge path is D:\MDaemon\WorldClient\HTML.well-known\Acme-challenge.
The State Path is D:\MDaemon\PEM_LEState.
The FQDN is set to mail.iob.co.bw.
The email address is set to postmaster@mail.iob.co.bw.
Setting the system to use the LetsEncrypt Live Service.
Error: WorldClient must be listening on port 80. This script will stop now.
This is a critical error, the script will now stop.
My web server is (include version):
MDaemon Webmail HTTP server: v20.0.4
The operating system my web server runs on is (include version):
Windows Server 2012 R2
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
Yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
No
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @shakeelb, and welcome to the LE community forum :slight_smile:

I'm not familiar with that ACME client.
However, I do see that it has this error:

2 Likes

Hi rg305,

Thanks, please help us.

1 Like

The solution is already given in the log:

2 Likes

World client is listening on Port 80

MDaemon itself says it isn't. (But I can connect to the webmail, so something seems to be working.) Can you show the WorldClient settings window?

1 Like

Hi,
Please see below web client settings.

Maybe MDaemon is complaining about the single * in the port bindings? Perhaps you need to change *,*:80 to just *:80?

1 Like

Changed as suggested to *:80 but still getting same error.

Weird.

Maybe some MDaemon specific support channels might have the answer. It's currently not a Let's Encrypt issue (yet) as far as I can tell. It's MDaemon itself that's quitting the script due to that port 80 error.

2 Likes

Thanks for the support, let us check with MDaemon and get back.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.