Let’s Encrypt Authority X3 not work in Firefox 48.0.2


#1

Hello.
Today i install SSL sertificate for my domain and install firefox 48.0.2
But as i can see SSL sertificate not work in firefox:

Why SSL sertificate not worked?

P.S.: in google and opera SSL is work.


#2

Looks like you aren’t serving the intermediate correctly, the other browsers appear to work due to having it cached from another site. You can check this with a tool such as this one.


#3

What’s your domain name ? (Without that it’s not really possible to check and say what the error is ).


#4

Good day. I dont know what is was but now site open without problem with ssl … Problem solved with help time.


#5

Domain name guitaritems.com. Now i see that ssl is working but i have warning:

The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate. Learn more about this error. The fastest way to fix this problem is to contact your SSL provider.

Tell me please it should be for ssl Let’s Encrypt Authority X3 or no ?


#6

Looks like you’re using nginx, so assuming that you used certbot to get your certificate change your server config to use fullchain.pem instead of cert.pem.


#7

thank you it help me.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.