Let encrypt renewal email got again

#1

Hi ,

I got renewal email again today. I renewed last two week. When i check in SSL expiry website, it renewed already. Below is the screenshot when i checked about the ssl. Please have a look and advice for it. How can i check my website is renew or still need to renew.

Thanks.

#2

Previously, on January 17th, you also got a certificate for a number of subdomains:

            DNS:cdn.straatosphere.com
            DNS:cdn2.straatosphere.com
            DNS:cdn3.straatosphere.com
            DNS:cdn4.straatosphere.com
            DNS:straatosphere.com
            DNS:www.straatosphere.com

All those subdomains haven’t been renewed.

The most recent certificate is just for straatosphere.com, not even including the www subdomain.

You can check issued certificates on crt.sh: https://crt.sh/?q=%straatosphere.com

Without any information about the contents of your e-mail, we’re pretty much in the dark.

#3

Hi Osiris,

So, how should i do that for this? Please advice for me.

Thanks.

#4

Hi @aungsithu

you have some active certificates ( https://check-your-website.server-daten.de/?q=straatosphere.com ):

CRT-Id Issuer not before not after Domain names LE-Duplicate next LE
1334636340 CN=“cPanel, Inc. Certification Authority”, O=“cPanel, Inc.”, L=Houston, C=US, ST=TX 2019-03-30 23:00:00 2019-06-29 21:59:59 mail.straatosphere.com, webmail.straatosphere.com
1332173012 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-03-28 22:25:17 2019-06-26 21:25:17 straatosphere.com
1119274248 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-01-17 10:37:42 2019-04-17 09:37:42 cdn.straatosphere.com, cdn2.straatosphere.com, cdn3.straatosphere.com, cdn4.straatosphere.com, straatosphere.com, www.straatosphere.com
1109744862 CN=“cPanel, Inc. Certification Authority”, O=“cPanel, Inc.”, L=Houston, C=US, ST=TX 2019-01-13 23:00:00 2019-04-14 21:59:59 mail.straatosphere.com, webmail.straatosphere.com

But Letsencrypt doesn’t know if you use the certificate (2019-01-17) with a lot of domain names or if you don’t need that certificate.

So the mail is sent.

But: You have two dns entries:

Host T IP-Address is auth. ∑ Queries ∑ Timeout
straatosphere.com A 128.199.124.58 yes 2 0
AAAA yes
www.straatosphere.com C straatosphere.com yes 1 0
A 128.199.124.58 yes

Your certificate has only one domain name:

CN=straatosphere.com
	29.03.2019
	27.06.2019
expires in 81 days	straatosphere.com - 1 entry

So your www version isn’t secure.

So you should create one certificate with both domain names (non-www and www) and use that.

#5

Hi JuergenAuer,

I run below command

“sudo certbot certonly --nginx -d straatosphere.com -d www.straatosphere.com -d cdn.straatosphere.com -d cdn2.straatosphere.com -d cdn3.straatosphere.com -d cdn4.straatosphere.com

but i got this message. Please advice and how to continue?

"Saving debug log to /var/log/letsencrypt/letsencrypt.log

Plugins selected: Authenticator nginx, Installer nginx

Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org

Cert is due for renewal, auto-renewing…

Renewing an existing certificate

Performing the following challenges:

Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.

Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA."

Thanks.

#6

@JuergenAuer,

How can i renew only for www version please help me and let me know. I run many command line.

It doesn’t work. Please advice me thanks.

#7

How old is your Certbot?

There is a standard template from #help

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

#8

This means your certbot version is out of date and it’s likely defaulting to SNI authentication. Update your certbot to have it default to --http or just put --http on the command line. ( --dns is the other option.)

#9

Hi @JuergenAuer,
My version is the following.

Thanks.

#10

That’s quite old.

The Certbot PPA currently has version 0.31.0.

How is Certbot installed? Why isn’t it a newer version?

#11

Hi @mnordhoff,

I don’t know how to upgrade the Certbot version.

When i ran this command “sudo certbot renew --dry-run”, i got this message

" Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/straatosphere.com-0001.conf


Cert not due for renewal, but simulating renewal for dry run

Plugins selected: Authenticator standalone, Installer nginx

Starting new HTTPS connection (1): acme-staging.api.letsencrypt.org

Running pre-hook command: service nginx stop

Renewing an existing certificate

Performing the following challenges:

http-01 challenge for straatosphere.com

Waiting for verification…

Cleaning up challenges

nginx: [error] open() “/run/nginx.pid” failed (2: No such file or directory)


new certificate deployed with reload of nginx server; fullchain is

/etc/letsencrypt/live/straatosphere.com-0001/fullchain.pem



Processing /etc/letsencrypt/renewal/straatosphere.com.conf


Cert is due for renewal, auto-renewing…

Plugins selected: Authenticator nginx, Installer nginx

Starting new HTTPS connection (1): acme-staging.api.letsencrypt.org

Renewing an existing certificate

Performing the following challenges:

Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.

Attempting to renew cert (straatosphere.com) from /etc/letsencrypt/renewal/straatosphere.com.conf produced an unexpected error: Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA… Skipping.

The following certs could not be renewed:

/etc/letsencrypt/live/straatosphere.com/fullchain.pem (failure)


** DRY RUN: simulating ‘certbot renew’ close to cert expiry

** (The test certificates below have not been saved.)

The following certs were successfully renewed:

/etc/letsencrypt/live/straatosphere.com-0001/fullchain.pem (success)

The following certs could not be renewed:

/etc/letsencrypt/live/straatosphere.com/fullchain.pem (failure)

** DRY RUN: simulating ‘certbot renew’ close to cert expiry

** (The test certificates above have not been saved.)


Running post-hook command: service nginx start

Hook command “service nginx start” returned error code 1

Error output from service:

Job for nginx.service failed because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.

1 renew failure(s), 0 parse failure(s)".

Please advice me. Thanks.

#12

You use only the standard nginx - option.

Check

to find a newer version.

Or switch to certbot-auto.

#13

Hi @JuergenAuer,

Let me try on this, I will let you know the result. Thanks.

#14

@JuergenAuer,

Can i use this instruction?
https://dev-notes.eu/2016/09/upgrading-letsencrypt-auto-to-certbot/

#15

You’re probably already using the Certbot PPA. It just hasn’t been updated for some reason.

While you can switch to certbot-auto, it’s a bit complicated to do so without causing more problems.

Before doing major surgery, you should confirm how Certbot is installed now.

What do “which certbot”, “sudo which certbot” and “dpkg -l '*certbot*'” show?

#16

Hi @JuergenAuer and @mnordhoff,

When i do certbot-auto, the message show like that

"wget https://dl.eff.org/certbot-auto
–2019-04-08 07:49:09-- https://dl.eff.org/certbot-auto
Resolving dl.eff.org (dl.eff.org)… 151.101.0.201, 151.101.64.201, 151.101.128.201, …
Connecting to dl.eff.org (dl.eff.org)|151.101.0.201|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 63564 (62K) [application/octet-stream]
Saving to: ‘certbot-auto’

certbot-auto 100%[===================>] 62.07K --.-KB/s in 0.003s

2019-04-08 07:49:09 (18.1 MB/s) - ‘certbot-auto’ saved [63564/63564]

root@straat-server-sgp1:~# chmod a+x ./certbot-auto
root@straat-server-sgp1:~# ./certbot-auto --help
Usage: certbot-auto [OPTIONS]
A self-updating wrapper script for the Certbot ACME client. When run, updates
to both this script and certbot will be downloaded and installed. After
ensuring you have the latest versions installed, certbot will be invoked with
all arguments you have provided.

Help for certbot itself cannot be provided until it is installed.

–debug attempt experimental installation
-h, --help print this help
-n, --non-interactive, --noninteractive run without asking for user input
–no-bootstrap do not install OS dependencies
–no-self-upgrade do not download updates
–os-packages-only install OS dependencies and exit
–install-only install certbot, upgrade if needed, and exit
-v, --verbose provide more output
-q, --quiet provide only update/error output;
implies --non-interactive

All arguments are accepted and forwarded to the Certbot client when run.
root@straat-server-sgp1:~# ./certbot-auto --version
Bootstrapping dependencies for Debian-based OSes… (you can skip this with --no-bootstrap)
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Hit:2 http://ppa.launchpad.net/certbot/certbot/ubuntu xenial InRelease
Hit:3 http://mirrors.digitalocean.com/ubuntu xenial InRelease
Get:4 http://mirrors.digitalocean.com/ubuntu xenial-updates InRelease [109 kB]
Get:5 http://mirrors.digitalocean.com/ubuntu xenial-backports InRelease [107 kB]
Fetched 325 kB in 1s (257 kB/s)
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
openssl is already the newest version (1.0.2g-1ubuntu4.15).
The following packages were automatically installed and are no longer required:
letsencrypt linux-headers-4.4.0-101 linux-headers-4.4.0-101-generic
linux-headers-4.4.0-103 linux-headers-4.4.0-103-generic
linux-headers-4.4.0-104 linux-headers-4.4.0-104-generic
linux-headers-4.4.0-108 linux-headers-4.4.0-108-generic
linux-headers-4.4.0-109 linux-headers-4.4.0-109-generic
linux-headers-4.4.0-112 linux-headers-4.4.0-112-generic
linux-headers-4.4.0-119 linux-headers-4.4.0-119-generic
linux-headers-4.4.0-121 linux-headers-4.4.0-121-generic
linux-headers-4.4.0-124 linux-headers-4.4.0-124-generic
linux-headers-4.4.0-127 linux-headers-4.4.0-127-generic
linux-headers-4.4.0-128 linux-headers-4.4.0-128-generic
linux-headers-4.4.0-130 linux-headers-4.4.0-130-generic
linux-headers-4.4.0-133 linux-headers-4.4.0-133-generic
linux-headers-4.4.0-134 linux-headers-4.4.0-134-generic
linux-headers-4.4.0-137 linux-headers-4.4.0-137-generic
linux-headers-4.4.0-138 linux-headers-4.4.0-138-generic
linux-headers-4.4.0-139 linux-headers-4.4.0-139-generic
linux-headers-4.4.0-141 linux-headers-4.4.0-141-generic
linux-headers-4.4.0-142 linux-headers-4.4.0-142-generic
linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-64
linux-headers-4.4.0-64-generic linux-headers-4.4.0-66
linux-headers-4.4.0-66-generic linux-headers-4.4.0-70
linux-headers-4.4.0-70-generic linux-headers-4.4.0-71
linux-headers-4.4.0-71-generic linux-headers-4.4.0-72
linux-headers-4.4.0-72-generic linux-headers-4.4.0-75
linux-headers-4.4.0-75-generic linux-headers-4.4.0-78
linux-headers-4.4.0-78-generic linux-headers-4.4.0-79
linux-headers-4.4.0-79-generic linux-headers-4.4.0-81
linux-headers-4.4.0-81-generic linux-headers-4.4.0-83
linux-headers-4.4.0-83-generic linux-headers-4.4.0-87
linux-headers-4.4.0-87-generic linux-headers-4.4.0-89
linux-headers-4.4.0-89-generic linux-headers-4.4.0-91
linux-headers-4.4.0-91-generic linux-headers-4.4.0-92
linux-headers-4.4.0-92-generic linux-headers-4.4.0-93
linux-headers-4.4.0-93-generic linux-headers-4.4.0-96
linux-headers-4.4.0-96-generic linux-headers-4.4.0-97
linux-headers-4.4.0-97-generic linux-headers-4.4.0-98
linux-headers-4.4.0-98-generic linux-image-4.4.0-101-generic
linux-image-4.4.0-103-generic linux-image-4.4.0-104-generic
linux-image-4.4.0-108-generic linux-image-4.4.0-109-generic
linux-image-4.4.0-112-generic linux-image-4.4.0-119-generic
linux-image-4.4.0-121-generic linux-image-4.4.0-124-generic
linux-image-4.4.0-127-generic linux-image-4.4.0-128-generic
linux-image-4.4.0-130-generic linux-image-4.4.0-133-generic
linux-image-4.4.0-134-generic linux-image-4.4.0-137-generic
linux-image-4.4.0-138-generic linux-image-4.4.0-139-generic
linux-image-4.4.0-141-generic linux-image-4.4.0-142-generic
linux-image-4.4.0-62-generic linux-image-4.4.0-64-generic
linux-image-4.4.0-66-generic linux-image-4.4.0-70-generic
linux-image-4.4.0-71-generic linux-image-4.4.0-72-generic
linux-image-4.4.0-75-generic linux-image-4.4.0-78-generic
linux-image-4.4.0-79-generic linux-image-4.4.0-81-generic
linux-image-4.4.0-83-generic linux-image-4.4.0-87-generic
linux-image-4.4.0-89-generic linux-image-4.4.0-91-generic
linux-image-4.4.0-92-generic linux-image-4.4.0-93-generic
linux-image-4.4.0-96-generic linux-image-4.4.0-97-generic
linux-image-4.4.0-98-generic
Use ‘apt autoremove’ to remove them.
The following additional packages will be installed:
binutils cpp cpp-5 gcc-5 gcc-5-base libasan2 libatomic1 libc-dev-bin libc6
libc6-dev libcc1-0 libcilkrts5 libexpat1-dev libgcc-5-dev libgomp1 libisl15
libitm1 liblsan0 libmpc3 libmpx0 libpython-dev libpython-stdlib libpython2.7
libpython2.7-dev libquadmath0 libstdc++6 libtsan0 libubsan0 linux-libc-dev
python-minimal python-pip-whl python2.7-dev python3-virtualenv zlib1g
zlib1g-dev
Suggested packages:
augeas-doc binutils-doc cpp-doc gcc-5-locales gcc-multilib make manpages-dev
autoconf automake libtool flex bison gdb gcc-doc gcc-5-multilib gcc-5-doc
libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan2-dbg
liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libmpx0-dbg
libquadmath0-dbg augeas-tools glibc-doc python-doc python-tk
Recommended packages:
manpages-dev libssl-doc
The following NEW packages will be installed:
augeas-lenses binutils cpp cpp-5 gcc gcc-5 libasan2 libatomic1 libaugeas0
libc-dev-bin libc6-dev libcc1-0 libcilkrts5 libexpat1-dev libffi-dev
libgcc-5-dev libgomp1 libisl15 libitm1 liblsan0 libmpc3 libmpx0
libpython-dev libpython2.7 libpython2.7-dev libquadmath0 libssl-dev libtsan0
libubsan0 linux-libc-dev python-dev python-pip-whl python-virtualenv
python2.7-dev python3-virtualenv virtualenv zlib1g-dev
The following packages will be upgraded:
ca-certificates gcc-5-base libc6 libpython-stdlib libstdc++6 python
python-minimal zlib1g
8 upgraded, 37 newly installed, 0 to remove and 158 not upgraded.
Need to get 61.2 MB of archives.
After this operation, 153 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 python-minimal amd64 2.7.12-1~16.04 [28.1 kB]
Get:2 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 python amd64 2.7.12-1~16.04 [137 kB]
Get:3 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libpython-stdlib amd64 2.7.12-1~16.04 [7768 B]
Get:4 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libc6 amd64 2.23-0ubuntu11 [2577 kB]
Get:5 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 libmpc3 amd64 1.0.3-1 [39.7 kB]
Get:6 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 zlib1g amd64 1:1.2.8.dfsg-2ubuntu4.1 [51.2 kB]
Get:7 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 gcc-5-base amd64 5.4.0-6ubuntu1~16.04.11 [17.3 kB]
Get:8 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libstdc++6 amd64 5.4.0-6ubuntu1~16.04.11 [393 kB]
Get:9 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 ca-certificates all 20170717~16.04.2 [167 kB]
Get:10 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 augeas-lenses all 1.4.0-0ubuntu1.1 [263 kB]
Get:11 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 binutils amd64 2.26.1-1ubuntu1~16.04.8 [2312 kB]
Get:12 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 libisl15 amd64 0.16.1-1 [524 kB]
Get:13 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 cpp-5 amd64 5.4.0-6ubuntu1~16.04.11 [7660 kB]
Get:14 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 cpp amd64 4:5.3.1-1ubuntu1 [27.7 kB]
Get:15 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libcc1-0 amd64 5.4.0-6ubuntu1~16.04.11 [38.8 kB]
Get:16 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libgomp1 amd64 5.4.0-6ubuntu1~16.04.11 [55.0 kB]
Get:17 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libitm1 amd64 5.4.0-6ubuntu1~16.04.11 [27.4 kB]
Get:18 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libatomic1 amd64 5.4.0-6ubuntu1~16.04.11 [8896 B]
Get:19 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libasan2 amd64 5.4.0-6ubuntu1~16.04.11 [264 kB]
Get:20 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 liblsan0 amd64 5.4.0-6ubuntu1~16.04.11 [105 kB]
Get:21 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libtsan0 amd64 5.4.0-6ubuntu1~16.04.11 [244 kB]
Get:22 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libubsan0 amd64 5.4.0-6ubuntu1~16.04.11 [95.4 kB]
Get:23 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libcilkrts5 amd64 5.4.0-6ubuntu1~16.04.11 [40.1 kB]
Get:24 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libmpx0 amd64 5.4.0-6ubuntu1~16.04.11 [9748 B]
Get:25 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libquadmath0 amd64 5.4.0-6ubuntu1~16.04.11 [131 kB]
Get:26 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libgcc-5-dev amd64 5.4.0-6ubuntu1~16.04.11 [2229 kB]
Get:27 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 gcc-5 amd64 5.4.0-6ubuntu1~16.04.11 [8417 kB]
Get:28 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 gcc amd64 4:5.3.1-1ubuntu1 [5244 B]
Get:29 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libaugeas0 amd64 1.4.0-0ubuntu1.1 [154 kB]
Get:30 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libc-dev-bin amd64 2.23-0ubuntu11 [68.5 kB]
Get:31 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 linux-libc-dev amd64 4.4.0-145.171 [874 kB]
Get:32 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libc6-dev amd64 2.23-0ubuntu11 [2086 kB]
Get:33 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libexpat1-dev amd64 2.1.0-7ubuntu0.16.04.3 [115 kB]
Get:34 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libpython2.7 amd64 2.7.12-1ubuntu0~16.04.4 [1071 kB]
Get:35 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libpython2.7-dev amd64 2.7.12-1ubuntu0~16.04.4 [27.8 MB]
Get:36 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libpython-dev amd64 2.7.12-1~16.04 [7840 B]
Get:37 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 zlib1g-dev amd64 1:1.2.8.dfsg-2ubuntu4.1 [168 kB]
Get:38 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 libssl-dev amd64 1.0.2g-1ubuntu4.15 [1344 kB]
Get:39 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 python2.7-dev amd64 2.7.12-1ubuntu0~16.04.4 [276 kB]
Get:40 http://mirrors.digitalocean.com/ubuntu xenial-updates/main amd64 python-dev amd64 2.7.12-1~16.04 [1186 B]
Get:41 http://mirrors.digitalocean.com/ubuntu xenial-updates/universe amd64 python-pip-whl all 8.1.1-2ubuntu0.4 [1110 kB]
Get:42 http://mirrors.digitalocean.com/ubuntu xenial-updates/universe amd64 python-virtualenv all 15.0.1+ds-3ubuntu1 [46.6 kB]
Get:43 http://mirrors.digitalocean.com/ubuntu xenial-updates/universe amd64 python3-virtualenv all 15.0.1+ds-3ubuntu1 [43.2 kB]
Get:44 http://mirrors.digitalocean.com/ubuntu xenial-updates/universe amd64 virtualenv all 15.0.1+ds-3ubuntu1 [4342 B]
Get:45 http://mirrors.digitalocean.com/ubuntu xenial/main amd64 libffi-dev amd64 3.2.1-4 [161 kB]
Fetched 61.2 MB in 12s (4717 kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “en_US.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_US.UTF-8”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Extracting templates from packages: 100%
Preconfiguring packages …
(Reading database … 1174572 files and directories currently installed.)
Preparing to unpack …/python-minimal_2.7.12-1~16.04_amd64.deb …
Unpacking python-minimal (2.7.12-1~16.04) over (2.7.11-1) …
Processing triggers for man-db (2.7.5-1) …
Setting up python-minimal (2.7.12-1~16.04) …
(Reading database … 1174572 files and directories currently installed.)
Preparing to unpack …/python_2.7.12-1~16.04_amd64.deb …
Unpacking python (2.7.12-1~16.04) over (2.7.11-1) …
Preparing to unpack …/libpython-stdlib_2.7.12-1~16.04_amd64.deb …
Unpacking libpython-stdlib:amd64 (2.7.12-1~16.04) over (2.7.11-1) …
Preparing to unpack …/libc6_2.23-0ubuntu11_amd64.deb …
Unpacking libc6:amd64 (2.23-0ubuntu11) over (2.23-0ubuntu10) …
Setting up libc6:amd64 (2.23-0ubuntu11) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Processing triggers for man-db (2.7.5-1) …
Selecting previously unselected package libmpc3:amd64.
(Reading database … 1174572 files and directories currently installed.)
Preparing to unpack …/libmpc3_1.0.3-1_amd64.deb …
Unpacking libmpc3:amd64 (1.0.3-1) …
Preparing to unpack …/zlib1g_1%3a1.2.8.dfsg-2ubuntu4.1_amd64.deb …
Unpacking zlib1g:amd64 (1:1.2.8.dfsg-2ubuntu4.1) over (1:1.2.8.dfsg-2ubuntu4) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Setting up zlib1g:amd64 (1:1.2.8.dfsg-2ubuntu4.1) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
(Reading database … 1174577 files and directories currently installed.)
Preparing to unpack …/gcc-5-base_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking gcc-5-base:amd64 (5.4.0-6ubuntu1~16.04.11) over (5.4.0-6ubuntu1~16.04.10) …
Setting up gcc-5-base:amd64 (5.4.0-6ubuntu1~16.04.11) …
(Reading database … 1174577 files and directories currently installed.)
Preparing to unpack …/libstdc++6_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libstdc++6:amd64 (5.4.0-6ubuntu1~16.04.11) over (5.4.0-6ubuntu1~16.04.10) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Setting up libstdc++6:amd64 (5.4.0-6ubuntu1~16.04.11) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
(Reading database … 1174577 files and directories currently installed.)
Preparing to unpack …/ca-certificates_20170717~16.04.2_all.deb …
Unpacking ca-certificates (20170717~16.04.2) over (20170717~16.04.1) …
Selecting previously unselected package augeas-lenses.
Preparing to unpack …/augeas-lenses_1.4.0-0ubuntu1.1_all.deb …
Unpacking augeas-lenses (1.4.0-0ubuntu1.1) …
Selecting previously unselected package binutils.
Preparing to unpack …/binutils_2.26.1-1ubuntu1~16.04.8_amd64.deb …
Unpacking binutils (2.26.1-1ubuntu1~16.04.8) …
Selecting previously unselected package libisl15:amd64.
Preparing to unpack …/libisl15_0.16.1-1_amd64.deb …
Unpacking libisl15:amd64 (0.16.1-1) …
Selecting previously unselected package cpp-5.
Preparing to unpack …/cpp-5_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking cpp-5 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package cpp.
Preparing to unpack …/cpp_4%3a5.3.1-1ubuntu1_amd64.deb …
Unpacking cpp (4:5.3.1-1ubuntu1) …
Selecting previously unselected package libcc1-0:amd64.
Preparing to unpack …/libcc1-0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libcc1-0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libgomp1:amd64.
Preparing to unpack …/libgomp1_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libgomp1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libitm1:amd64.
Preparing to unpack …/libitm1_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libitm1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libatomic1:amd64.
Preparing to unpack …/libatomic1_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libatomic1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libasan2:amd64.
Preparing to unpack …/libasan2_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libasan2:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package liblsan0:amd64.
Preparing to unpack …/liblsan0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking liblsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libtsan0:amd64.
Preparing to unpack …/libtsan0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libtsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libubsan0:amd64.
Preparing to unpack …/libubsan0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libubsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libcilkrts5:amd64.
Preparing to unpack …/libcilkrts5_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libcilkrts5:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libmpx0:amd64.
Preparing to unpack …/libmpx0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libmpx0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libquadmath0:amd64.
Preparing to unpack …/libquadmath0_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libquadmath0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package libgcc-5-dev:amd64.
Preparing to unpack …/libgcc-5-dev_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking libgcc-5-dev:amd64 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package gcc-5.
Preparing to unpack …/gcc-5_5.4.0-6ubuntu1~16.04.11_amd64.deb …
Unpacking gcc-5 (5.4.0-6ubuntu1~16.04.11) …
Selecting previously unselected package gcc.
Preparing to unpack …/gcc_4%3a5.3.1-1ubuntu1_amd64.deb …
Unpacking gcc (4:5.3.1-1ubuntu1) …
Selecting previously unselected package libaugeas0.
Preparing to unpack …/libaugeas0_1.4.0-0ubuntu1.1_amd64.deb …
Unpacking libaugeas0 (1.4.0-0ubuntu1.1) …
Selecting previously unselected package libc-dev-bin.
Preparing to unpack …/libc-dev-bin_2.23-0ubuntu11_amd64.deb …
Unpacking libc-dev-bin (2.23-0ubuntu11) …
Selecting previously unselected package linux-libc-dev:amd64.
Preparing to unpack …/linux-libc-dev_4.4.0-145.171_amd64.deb …
Unpacking linux-libc-dev:amd64 (4.4.0-145.171) …
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack …/libc6-dev_2.23-0ubuntu11_amd64.deb …
Unpacking libc6-dev:amd64 (2.23-0ubuntu11) …
Selecting previously unselected package libexpat1-dev:amd64.
Preparing to unpack …/libexpat1-dev_2.1.0-7ubuntu0.16.04.3_amd64.deb …
Unpacking libexpat1-dev:amd64 (2.1.0-7ubuntu0.16.04.3) …
Selecting previously unselected package libpython2.7:amd64.
Preparing to unpack …/libpython2.7_2.7.12-1ubuntu0~16.04.4_amd64.deb …
Unpacking libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.4) …
Selecting previously unselected package libpython2.7-dev:amd64.
Preparing to unpack …/libpython2.7-dev_2.7.12-1ubuntu0~16.04.4_amd64.deb …
Unpacking libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.4) …
Selecting previously unselected package libpython-dev:amd64.
Preparing to unpack …/libpython-dev_2.7.12-1~16.04_amd64.deb …
Unpacking libpython-dev:amd64 (2.7.12-1~16.04) …
Selecting previously unselected package zlib1g-dev:amd64.
Preparing to unpack …/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4.1_amd64.deb …
Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu4.1) …
Selecting previously unselected package libssl-dev:amd64.
Preparing to unpack …/libssl-dev_1.0.2g-1ubuntu4.15_amd64.deb …
Unpacking libssl-dev:amd64 (1.0.2g-1ubuntu4.15) …
Selecting previously unselected package python2.7-dev.
Preparing to unpack …/python2.7-dev_2.7.12-1ubuntu0~16.04.4_amd64.deb …
Unpacking python2.7-dev (2.7.12-1ubuntu0~16.04.4) …
Selecting previously unselected package python-dev.
Preparing to unpack …/python-dev_2.7.12-1~16.04_amd64.deb …
Unpacking python-dev (2.7.12-1~16.04) …
Selecting previously unselected package python-pip-whl.
Preparing to unpack …/python-pip-whl_8.1.1-2ubuntu0.4_all.deb …
Unpacking python-pip-whl (8.1.1-2ubuntu0.4) …
Selecting previously unselected package python-virtualenv.
Preparing to unpack …/python-virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking python-virtualenv (15.0.1+ds-3ubuntu1) …
Selecting previously unselected package python3-virtualenv.
Preparing to unpack …/python3-virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking python3-virtualenv (15.0.1+ds-3ubuntu1) …
Selecting previously unselected package virtualenv.
Preparing to unpack …/virtualenv_15.0.1+ds-3ubuntu1_all.deb …
Unpacking virtualenv (15.0.1+ds-3ubuntu1) …
Selecting previously unselected package libffi-dev:amd64.
Preparing to unpack …/libffi-dev_3.2.1-4_amd64.deb …
Unpacking libffi-dev:amd64 (3.2.1-4) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Processing triggers for install-info (6.1.0.dfsg.1-5) …
Setting up libpython-stdlib:amd64 (2.7.12-1~16.04) …
Setting up python (2.7.12-1~16.04) …
Setting up libmpc3:amd64 (1.0.3-1) …
Setting up ca-certificates (20170717~16.04.2) …
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up augeas-lenses (1.4.0-0ubuntu1.1) …
Setting up binutils (2.26.1-1ubuntu1~16.04.8) …
Setting up libisl15:amd64 (0.16.1-1) …
Setting up cpp-5 (5.4.0-6ubuntu1~16.04.11) …
Setting up cpp (4:5.3.1-1ubuntu1) …
Setting up libcc1-0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libgomp1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libitm1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libatomic1:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libasan2:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up liblsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libtsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libubsan0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libcilkrts5:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libmpx0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libquadmath0:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up libgcc-5-dev:amd64 (5.4.0-6ubuntu1~16.04.11) …
Setting up gcc-5 (5.4.0-6ubuntu1~16.04.11) …
Setting up gcc (4:5.3.1-1ubuntu1) …
Setting up libaugeas0 (1.4.0-0ubuntu1.1) …
Setting up libc-dev-bin (2.23-0ubuntu11) …
Setting up linux-libc-dev:amd64 (4.4.0-145.171) …
Setting up libc6-dev:amd64 (2.23-0ubuntu11) …
Setting up libexpat1-dev:amd64 (2.1.0-7ubuntu0.16.04.3) …
Setting up libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.4) …
Setting up libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.4) …
Setting up libpython-dev:amd64 (2.7.12-1~16.04) …
Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu4.1) …
Setting up libssl-dev:amd64 (1.0.2g-1ubuntu4.15) …
Setting up python2.7-dev (2.7.12-1ubuntu0~16.04.4) …
Setting up python-dev (2.7.12-1~16.04) …
Setting up python-pip-whl (8.1.1-2ubuntu0.4) …
Setting up python-virtualenv (15.0.1+ds-3ubuntu1) …
Setting up python3-virtualenv (15.0.1+ds-3ubuntu1) …
Setting up virtualenv (15.0.1+ds-3ubuntu1) …
Setting up libffi-dev:amd64 (3.2.1-4) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Processing triggers for ca-certificates (20170717~16.04.2) …
Updating certificates in /etc/ssl/certs…
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
done.
Creating virtual environment…
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 2363, in
main()
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 719, in main
symlink=options.symlink)
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 988, in create_environment
download=download,
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 918, in install_wheel
call_subprocess(cmd, show_stdout=False, extra_env=env, stdin=SCRIPT)
File “/usr/lib/python3/dist-packages/virtualenv.py”, line 812, in call_subprocess
% (cmd_desc, proc.returncode))
OSError: Command /opt/eff.org/certbot/venv/bin/python2.7 - setuptools pkg_resources pip wheel failed with error code 1
Traceback (most recent call last):
File “”, line 27, in
File “”, line 19, in create_venv
File “/usr/lib/python2.7/subprocess.py”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘virtualenv’, ‘–no-site-packages’, ‘–python’, ‘/usr/bin/python2.7’, ‘/opt/eff.org/certbot/venv’]’ returned non-zero exit status 1".

how can i continue? Please advice me.

Thanks.

#17

Don’t try certbot-auto for now.

Please answer the questions I asked before.

certbot-auto did show that your system has tons of packages that need to be upgraded.

Try running “sudo apt update”, “sudo apt upgrade” and “sudo apt full-upgrade”.

If Certbot is installed using the PPA packages, that should also upgrade it, and help resolve your other problem.

#18

Hi @mnordhoff,

Can i run below command?

Thanks.

#19

You should run those three commands.

(Actually, since you’re logged in as root, you don’t need to prefix them with “sudo”.)

Can you also run the other commands I asked about to investigate the Certbot situation?

#20

Hi @mnordhoff,

Now i running so many installing. What will be happening? :anguished: . Please let me know.