Le64.exe (Windows) - Invalid Content-Type header on POST. Content-Type must be "application/jose+json"


#1

Hi Everyone,
I use the Windows version of le64.exe - from https://github.com/do-know/Crypt-LE/releases to generate my LetsEncrypt SSL certificates.

Using a batch file I successfully generated my certificates and they worked perfectly. As a test I re-generated the certificates again 1 week later and that too ran fine.

However, now when I run exactly the same batch file in exactly the same way I get the message:

Invalid Content-Type header on POST. Content-Type must be “application/jose+json”

The full display is:

le64.exe -key LetsEncryptKey.txt -csr myCSR.csr -csr -key prikey.txt -domains “*.myDomain.co.uk” -crt myDomain_wildcard.crt -generate-missing -handle-as dns -api 2 -live

2018/04/03 11:59:44 [ ZeroSSL Crypt::LE client v0.30 started. ]
2018/04/03 11:59:44 Loading an account key from LetsEncryptKey.txt
2018/04/03 11:59:44 Loading a CSR from apartmentWildcardCSR.csr
2018/04/03 11:59:46 Registering the account key
2018/04/03 11:59:46 Invalid Content-Type header on POST. Content-Type must be “application/jose+json”

Can anyone help with what the issue is? It worked fine for at least a few attempts with a week between, then suddenly stopped working.

Thanks in advance,
Marcus


#2

Hi @marcusjclifford,

You should update to the last version, as far as I know this Content-Type change is commited in the last version.

Cheers,
sahsanu


#3

Thanks for your suggestion, but I am already on build 0.31 / 38dcb70 which I believe is the latest build (released 18 days ago) - further commits seem to only be for readme updates.


#4

Having just said that, although I thought I was on the latest release I re-downloaded the .exe file, and it now works!

The original version of le64.exe I had was version 0.30, but now I have version 0.31 and indeed it works correctly now, so thank you for your suggestion - it made me re-check that and solved my issue.


#5

As @sahsanu correctly pointed out, that has been covered in v0.31, which has been made available about a week before those API changes went live. I have now added a specific note to the release page to highlight this.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.