Key authorization file error, even though the match

I am trying to get a certificate for my website using certbot on my PC.
I am running the command:
cerbot certonly --manual
I go through all the steps, but when I have to verify that I am actually owning the server I get a strange error:

  • The following errors were reported by the server:

    Domain: not important
    Type: unauthorized
    Detail: The key authorization file from the server did not match
    this challenge

To me these strings look exactly the same. I therefore do not understand why it is not working.
Thank you for your help

Hi @2jonathan

please answer the following questions. That’s the standard template of #help

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Your domain is the most important information.

This is probably because you have smuggled a Unicode Byte Order Mark into the first bytes of the file.

If you view the hex:

cat _d7nZ1MkdBFFX0mcMoPYhuMsYn3GMe3LXdPvglYeH3Q | xxd

you would probably see something like:

0000000: efbb bf5f 6437 6e5a 314d 6b64 4246 4658  ..._d7nZ1MkdBFFX

The error message from Let's Encrypt does not include the BOM, because it has no visible representation.

This was probably caused by you using a certain text editor to create the file.


Thank you a lot, I have now used a different editor (nano) and it worked perfectly!

1 Like

Nice catch @_az :clap: That's a subtle one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.