It is possible to pause the redirect

Can I pause the redirect from http to https and then turn it back on? I have a Certbot certificate.

1 Like

Do you have enough access to edit your web config files?

And what “problem” are you trying to overcome?

1 Like

I have access to the files but I don’t know how to do it, the problem is that I have an app that points to http, for now I need to deactivate the redirection so that it can continue working until I make the change in the app and activate the redirection again, it is possible?

1 Like

Yes, and perhaps even more.

Which web server are you using? Apache, NGINX, …

1 Like

Did I lose you?
Let me explain what I meant by “even more”.
Depending on the web server software / version / added modules / etc.
You might be able to exclude redirection specifically only for your app.
If you can define the access by “your app” with at least one of the following:
a. unique source IP address/range
b. unique user agent
c. unique path {URI}
[or any combination]

The purpose of this “method” is that you won’t need to disable redirection for ALL connections.

We can always just disable the whole redirection - that should be very simple to do.

1 Like

Im using Apache, thank you is good that.

1 Like

Let’s start by reviewing the output of:
apachectl -S

1 Like

How can I do that? I ll like do it with unique path {URI}, I have a API for the Mobil App, route www.myweb.com/api/auth

ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

Have you removed any lines?
There should be IP:ports and servernames/aliases and their corresponding file names.

No, I dont change anything

Try with sudo:
sudo apachectl -S

Same, but I do a virtualhost, maybe is that?

Are you on the server that is running Apache?

My DocumentRoot its no “/var/www/html”

Yes, I Have a DiigitalOcean Droplet (Lamp ubuntu 20)

Which is the file that has the config for your HTTP connections?

I followed this tutorial: https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-20-04-es