Issues with ownership verification


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: plosz.ca

I ran this command: Sign challenge command for DNS record option.

It produced this output: Error: Challenge submission failed. Please start back at Step 1. { “type”: “urn:ietf:params:acme:error:malformed”, “detail”: “Unable to update challenge :: authorization is not pending”, “status”: 400 }

My web server is (include version): PHP 7.0.6, Apache 2

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Media Temple

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

I have tried using the file based and DNS record options, but both fail each and every time I try. DNS is managed at Go Daddy and the hosting is at Media Temple.

Any help is greatly appreciated. Cheers.


#2

Are you using https://gethttpsforfree.com/ or something else?


#3

Yes, I am using that service for setting up the SSL certificate.


#4

Maybe try this comment that shows how to collect more debugging information to determine what the issue is: https://github.com/diafygi/gethttpsforfree/issues/154#issuecomment-385555114

Otherwise, try using ZeroSSL, it essentially works the same way as gethttpsforfree.


#5

Thanks. I will check it out and let you know how it goes.