Is my IP banned? Can this be undone?


Iḿ using Nginx proxy manager but since a few weeks i get internal errors when requesting or renewing an certificate.

Nothing has changed in my network/dns or whatever.

So i did a clean install from npm but still doesnt work.

When i check the logs i see the following error. Can this be checked if my WAN IP ( is blocked and what do i need to do to get it unblocked and working again?

Error: Command failed: certbot certonly --config "/etc/letsencrypt.ini" --work-dir "/tmp/letsencrypt-lib" --logs-dir "/tmp/letsencrypt-log" --cert-name "npm-3" --agree-tos --authenticator webroot --email "" --preferred-challenges "dns,http" --domains ""
Saving debug log to /tmp/letsencrypt-log/letsencrypt.log
An unexpected error occurred:
requests.exceptions.ConnectionError: HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /directory (Caused by NameResolutionError(": Failed to resolve '' ([Errno -3] Temporary failure in name resolution)"))
Ask for help or search for solutions at See the logfile /tmp/letsencrypt-log/letsencrypt.log or re-run Certbot with -v for more details.

at ChildProcess.exithandler (node:child_process:402:12)
at ChildProcess.emit (node:events:513:28)
at maybeClose (node:internal/child_process:1100:16)
at Socket. (node:internal/child_process:458:11)
at Socket.emit (node:events:513:28)
at Pipe. (node:net:301:12)

With kind regards,

Buck Baggen

No, your DNS is malfunctioning as the error suggests.


Oh sorry then i did read it wrong.

I checked my DNS, i can ping google as example, but when i want to ping i get the error: name or service not known

To check if it is not my network, i tried from my work office (different network, different ISP, different WANIP etc.) But the same.

So i guess it is not a problem in my DNS?

Seems to be alright, just ran this:

$ dig @
;; ANSWER SECTION: 7200 IN   CNAME 300   IN      CNAME 300 IN A

A couple of issues:

  1. Indeed the name “” cannot exist in DNS, try pinging “
  2. This endpoint doesn't work with plain http, one must access it through https.

Oke, that was a bit stupid. I can indeed ping

So i searched in the DNS, cant find anything that is changed. I run NPM in a docker container and the compose file hasnt changed, neither something on the docker host or network.

But i added just to test one rule into the compose file from the npm container and now it works!


On the same level as environment

Strange, because without that rule it worked before, i had like 10 proxy hosts with ssl cert in npm.

Maybe something changed with an automatic update or so, i have no explanation but happy it works now :slight_smile:

Thanks for the support!


If I had a dollar for every time the docker daemon DNS service randomly crashed on me I would not need a job :laughing:.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.