Invalid response

We installed my certificates on various domains, via the same environment hosted by our hosting provider Realhosting. We never experience problems installing and renewing certificates. But no we experience problems om one of our client sites.

When using hospicedeliefde.nl in the browser, the site is protected and the loch shows. When adding www.hospicedeliefde.nl in the browser, the site still shows as unprotected.

During the installation we selected the option to add the subdomain www.

My domain is: hopspicedeliefde.nl

I ran this command: From within PLesk I installed Let’s Encrypt

It produced this output:
Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/2157040690.
Details:
Type: urn:ietf:params:acme:error:unauthorized
Status: 403
Detail: Invalid response from http://www.hospicedeliefde.nl/.well-known/acme-challenge/BsQxLNLuTZrENnd3IXzZNudr3qJayM_OM_kbUj7FVzc [192.166.97.14]: “\n\n404 Not Found\n\n

Not Found

\n<p”

My web server is (include version): unknown. The site is hosted by Realhosting

The operating system my web server runs on is (include version): unknown. The site is hosted by Realhosting

My hosting provider, if applicable, is: RealHosting

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
YES, Plesk webhost edition 9hosted by my hosting provider

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): unknown

Da’s klaarblijkelijk niet goed gegaan. Het certificaat omvat alléén hospicedeliefde.nl.

Het rare is, is dat er sinds 3 januari en op 7 januari alweer 5 certificaten voor die éne hostname aangemaakt zijn, terwijl het daarvóór tijden goed is gegaan: toen zat het www subdomein er wel gewoon bij.

Ik ga er van uit dat voorgaande tijd het automatisch goed ging? Waarom is er opeens op 3 januari “gekozen” om het www subdomein weg te laten?

Doordat je nu 5 certificaten met dezelfde hostname hebt aangemaakt, loop je tegen de duplicate certificate limiet aan. Doch, als je het www subdomein toevoegt, zou het wel mogelijk moeten zijn om weer een nieuw certificaat te verkrijgen.

Ik ben bang dat we weinig voor je kunnen betekeken als het allemaal via Plesk gaat. Als er namelijk iets mis met Plesk gaat, is eigenlijk alleen Realhosting de partij die het ook op kan lossen.

Ah, ook een leuke:

http://www.hospicedeliefde.nl/ geeft een standaard Plesk “placeholder” pagina weer en NIET je eigenlijke site. Er gaat dus iets gruwelijks mis met je Plesk instellingen t.a.v. het www subdomein.

Eérst je www.hospicedeliefde.nl goed zien te krijgen (als in: je daadwerkelijke site en niet een Plesk placeholder) en vervolgens proberen wederom je certificaat met en zonder www als hostname erin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.