Invalid Intermediate

Ran into an issue where my SSL padlock wouldn't show and ran through the whynopadlock check to find it's an invalid intermediate. I had no issues 2 days ago when I was working on the site on trial, but since upgrading my account I had to do another SSL cert.

I've read other threads mentioning similar issues, but I have not hardcoded the Let's Encrypt SSL, I ran it through Cloudways. I've read that it could be an issue with the ACME client, but I couldn't find any resources to figure out how to access/edit it.

My domain is:

I ran this command: n/a Let's encrypt via cloudways

It produced this output: You have an invalid or missing intermediate (bundle) certificate. This may not break your padlock on all browsers, but will on others. Please contact your SSL Vendor for assistance with this error. Via

My web server is (include version): digital ocean via cloudways

The operating system my web server runs on is (include version): Debian 8?

My hosting provider, if applicable, is: cloudways

I can login to a root shell on my machine (yes or no, or I don't know): no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

You can ignore the message from WhyNoPadlock. It has a bug. It cannot even validate its own site - try it. I wrote to them about 2 weeks ago but got nothing but a quick useless auto-reply.

Use a site like these to verify your certificate chain (SSL Labs gives you an A)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.