Invalid header value 'CertbotACMEClient/0.8.0'


#1

after update to v0.8.0 I got this error:

An unexpected error occurred: ValueError: Invalid header value 'CertbotACMEClient/0.8.0 (darwin 10.11.5\n) Authenticator/manual Installer/None' Please see the logfiles in /var/log/letsencrypt for more details.

Can anyone help to resolve this issue?
Thank you.


#2

@nguyenvanduocit, thank you for reporting this problem. This is a bug in the Certbot client.

I looked into it and determined the problem, but it turned out that other people had already reported it on GitHub:

And one contributor had suggested a fix, which I’ve just incorporated. If you’re able to update your client from git, the fixed version should now be in the tree. Otherwise, the fix should be included in the next release. In the worst case, you could try to apply the fix manually to your own copy of Certbot:

Sorry for the inconvenience!


#3

Thank you so much. I will move this post to ‘client’


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.