Installing letsencrypt on IIS 7 (intranet). Authorization Result Invalid


#1

I have a problem when setting up https on the intranet site.

My site is intranet site, cannot be accessed outside of my company network.

I have performed the below steps:

  1. Configured site as as like "http://testmachine.diago.com/
  2. Installed Agent as instructed by the command [letsencrypt-win-simple.v1.7] and file has been generated under C:\inetpub\wwwroot\diago.well-known/acme-challenge…
  3. Getting Authorization Result: invalid

The ACME server was probably unable to reach http://testmachine.diago.com/.well-known/acme-challenge/enCXgGHrlRjWkCkKSfGO6JAExM12ZIwavDaMcROhBqQ - But I am able to access this url

Check in a browser to see if the answer file is being served correctly.

This could be caused by IIS not being setup to handle extensionless static
files. Here’s how to fix that:

  1. In IIS manager goto Site/Server->Handler Mappings->View Ordered List
  2. Move the StaticFile mapping above the ExtensionlessUrlHandler mappings.
    (like this http://i.stack.imgur.com/nkvrL.png)

All above settings are correct, But https not working. Could you please some one help me on this?


#2

I’m a little confused, but that happens often for me :wink:

If this is an intranet site, not accessible from outside your company network, how do you expect LE to reach it to confirm that URL ? I can’t access it ( but then I probably shouldn’t be able to, like LE, as I’m outside your network).

am I missing something ? the LE server can only check it if there is access generally from the internet.