Install certbot on Ubuntu Nextcloud appliance core 18

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: birkhofer.kozow.com

I ran this command: sudo snap install --classic certbot

It produced this output: error: snap "certbot" requires classic confinement which is only available on classic systems

My web server is (include version): Apache, 2.4 (I am assuming it's 2.4.46)

The operating system my web server runs on is (include version): ubuntu core 18 nextcloud appliance

My hosting provider, if applicable, is: Me

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I am simply trying to get a certificate for my nextcloud instance and I am have trouble moving through the snap environment. There is a certbot snap but as you can see by my output above I cant install it. Anybody else delt with this and solved it?

2 Likes

And then I found sudo nextcloud.enable-https lets-encrypt and that worked. Thanks though!

4 Likes

Kudos to NextCloud for taking that extra minute to write the script that integrates certificate issuance into their specific software - no one understands software intricacies any better than the maintainer.

Again, thanks to NextCloud for making all our lives that much more simpler!
[and thank you @jlb181 for posting that solution here for others to find and enjoy]

Cheers from Miami :beers:

3 Likes