Incorrect validation certificate - cert had names 'vmware'?


#1

Hi,

I’m running Apache2 on Debian (Wheezy) - I’ve previously used LE on my Jessie server with no issues.
I’ve run ./certbot-auto --apache

And I’ve I’ve got the following response:

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: dev.jomomail.co.uk
Type: unauthorized
Detail: Incorrect validation certificate for TLS-SNI-01 challenge.
Requested
1cbd2152d22cc0eca06600e715bc88af.cfc205a18a89890fc0a9bafb3c185947.acme.invalid
from 213.152.37.97:443. Received 1 certificate(s), first
certificate had names “vmware”

Domain: brandon.itjustdone.co.uk
Type: unauthorized
Detail: Incorrect validation certificate for TLS-SNI-01 challenge.
Requested
ca1a958bd271c956e776a37a2b9c53f7.9bb07e282a82d58076bfbfe7dbbe0455.acme.invalid
from 213.152.37.97:443. Received 1 certificate(s), first
certificate had names “vmware”

Domain: development.furnessvale.derbyshire.sch.uk
Type: unauthorized
Detail: Incorrect validation certificate for TLS-SNI-01 challenge.
Requested
d8d7431b068f53970bc7dc2c33619eb6.ddfd7ac20ca0a52991ce686f17d0ead0.acme.invalid
from 213.152.37.97:443. Received 1 certificate(s), first
certificate had names “vmware”

The hostnames work on port 80, so I’m happy DNS is correct. That machine does have vmware installed, but I can’t see how / where it’s interfering?

TIA,

Joe


#2

Using the tls-01 challenge it’s trying to connect on port 443 (https ). Is that forwarded correctly to the device ?


#3

In case it helps anyone else:

I ran netstat -tulpn to find the process running on 443 - it was vmware-hostd

Even though I wasn’t running the VMWare console (I run my VMs from command-line), the remote access server was running. To disable, I opened VMWare Workstation on the desktop, clicked edit and preferences. In the Shared VMs section was the option to disable sharing or change the port. I disabled sharing. I then closed Workstation, choosing run in background so my existing VMs were unaffected.

Thanks for the reply, apologies for not working something simple out myself!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.