Incorrect TLS-SNI-01 challenge


#1

Hello,

I am quite new to LE, so would appreciate any support.
My commercial certificate expired, so I am trying use LE with certbot. I’ve checked all that was able to find on similar topics, but none of that helped.

I ran this commands:
a) ./certbot-auto
b)./certbot-auto certonly --webroot -w /var/www/html/wordpress -d www.cirt.gov.bd -d cirt.gov.bd

It produced this output:
a) IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cirt.gov.bd
    Type: unauthorized
    Detail: Incorrect validation certificate for TLS-SNI-01 challenge.
    Requested
    e326a64bb6c22d9619ac311acf0093d6.c266443386fda2fc0a1db1b73f1ef6c5.acme.invalid
    from 103.48.16.54:443. Received certificate containing
    www.cirt.gov.bd, cirt.gov.bd

#########
b) IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cirt.gov.bd
    Type: connection
    Detail: Could not connect to www.cirt.gov.bd.well-known

    Domain: www.cirt.gov.bd
    Type: connection
    Detail: Could not connect to www.cirt.gov.bd.well-known

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My operating system is (include version):
Ubuntu 14.04.3 LTS

My web server is (include version):
Apache/2.4.7

I can login to a root shell on my machine (yes or no, or I don’t know): YES

As I understand I shouldn’t disable existing SSL first.
What further steps should I take?

Thank you, for you support!


#2

For b): your domain has a broken redirect for the non-www-domain to the www-domain: it’s missing a slash.


#3

Thank you so much, Osiris! After redirect statment was corrected, b) works just fine:)


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.