I'm getting http-01 503 Errors with a clean install

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
patmac.cloud
I ran this command:
sudo certbot-certonly domain patmac.cloud --email patrick@patmac.co.uk
It produced this output:
Use of --tls-sni-01-port is deprecated.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Starting new HTTPS connection (1): acme-staging-v02.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for patmac.cloud
Waiting for verification…
Challenge failed for domain patmac.cloud
http-01 challenge for patmac.cloud
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: patmac.cloud
    Type: unauthorized
    Detail: Invalid response from
    http://patmac.cloud/.well-known/acme-challenge/GxtUlz4TxSSefoG_xSeDaoq8L7wzyXzHgwZxvGgFAT8
    [82.15.9.101]: 503

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.
    My web server is (include version):
    Thingsboard 2.4 installed clean from scratch
    The operating system my web server runs on is (include version):
    Centos 7.6
    My hosting provider, if applicable, is:
    Self hosting all access to DNS Server is rented by Fasthosts
    I can login to a root shell on my machine (yes or no, or I don’t know):
    Yes all access
    I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
    Domain and DNS is handled by main server at fasthosts using plesk there. machine in question is just a node
    The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.36.0 haproxy-1.7.3
    Comment : Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

1 Like

Hi @Patmac

checking your domain you see the problem ( https://check-your-website.server-daten.de/?q=patmac.cloud ):

Domainname Http-Status redirect Sec. G
• http://patmac.cloud/
82.15.9.101 200 0.103 H
small content:
• http://www.patmac.cloud/
82.15.9.101 200 0.100 H
small content:
• https://patmac.cloud/
82.15.9.101 -14 10.010 T
Timeout - The operation has timed out
• https://www.patmac.cloud/
82.15.9.101 -14 10.020 T
Timeout - The operation has timed out
• http://patmac.cloud/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
82.15.9.101 503 0.084 S
Service Unavailable
Visible Content: 503 Service Unavailable No server is available to handle this request.
• http://www.patmac.cloud/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
82.15.9.101 503 0.086 S
Service Unavailable
Visible Content: 503 Service Unavailable No server is available to handle this request.

http + your domain works.

But http + /.well-known/acme-challenge - looks like there is a proxy configured, but the destination doesn’t answer.

Result: A http status 503 - Service Unavailable No server is available to handle this request.

So

  • remove that proxy setup (or)
  • fix it, so /.well-known/acme-challenge works.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.