IIS with ASP not working

I have been totally unsuccessful getting letsencrypt to work with IIS 8.5
The ACME server cannot reach the URL. I can manually.
I have adjusted the Handler mappings and edited the web.config file.

If I use ASP in my Application pool, I cannot even browse the folder and the patches make no difference.

Why does letsencrypt have to use leading dots and special characters in the folder and file names? There is no reason to do this.

Letencrypt is really not fully compatible with IIS and should be avoided as to not waste your time.

how did you install “letsencrypt.exe”?
and what version is it?

I tried with Certify, and also tried manually via the command prompt

you don’t need to recreate the folders with the leading dots.
But if you insist on doing that, try:
mkdir /.folder.
(with a leading dot and a trailing dot)

I use le64.exe on windows 2012 without any issues.

Not recreating folders. They are created by the program, which is the currect version on the website now Certify is version

The folders are fine and the files are created correctly. I just never can pass the authorizing phase

This judgement seems a bit premature and misplaced.
You are having trouble with "Certify" and IIS, but place the blame on LE?

Is there anything useful in the logs?

Doesn’t work doing it manually via command prompt. Tried two different systems and there are lots of similar complaints around the web, even on this forum. I wasted three days and still no results.

Can you show this work?

and yet you've only been on the community forum 16 minutes...

does letsencrypt create a log? there is nothing in the event logs. The website itself works fine.
I tried the mime settings and moved the static mapping as per the suggestions

usually, but I'm not too familiar with Certify

where would the letsencrypt log be located?

I just tried Certify as another test. I am actually trying to just use the letsencrypt.exe program

I’d start with:
letsencrypt -help

or maybe checkout:

will check out letsencrypt-win-simple
–help didn’t provide any answers

win-simple was what I already tried. Doesn’t work either

Do you have any more detailed information on the failure, like the error message from the LE verification server? Please make sure to fill out the form that pops up when you make a new topic in Help, as it provides information that help the community and Let’s Encrypt folks help you. I’ll paste the questions below for you.

As for compatibility, Let’s Encrypt the service doesn’t have any compatibility issues. It’ll work with any client that supports the ACME protocol for certificate issuance. There are a number of clients that do this, including the certbot reference client. Lets-encrypt-win-simple (letsencrypt.exe) is one third-party client that works on Windows.

As one quick note, I know there have been some situations where an IPv6 address was set up for a domain, but not actually used. In situations where both an IPv6 and IPv4 address are present, LE will check on the IPv6 address first. Due to a bug, if the IPv6 attempt fails then it won’t try the IPv4 address (this is scheduled to be fixed).

The questions:

Please fill out the fields below so we can help you better.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):