I receive a warning saying ERR_CERT_COMMON_NAME_INVALID

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.cefeel.com

I ran this command: certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?

1: www.cefeel.com

Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel): 1
Obtaining a new certificate
Deploying Certificate to VirtualHost /etc/httpd/conf/httpd.conf
Enhancement redirect was already set.

Congratulations! You have successfully enabled https://www.cefeel.com


  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2021-06-19. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the "certonly" option. To non-interactively renew all of
    your certificates, run "certbot renew"

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let's Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My web server is (include version): apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: oracle cloud

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.6.0


Hi @sksamal

your configuration looks buggy, because Certbot shows only one domain name.

What says

apachectl -S

You should add cefeel.com to the existing certificate you created, and a redirect to whichever domain you want users to end up at. Currently, only your page at cefeel.com shows up. (Beautiful photo at the top! :smiley: ) I see you have a redirect from the www version to the non-www version (which is where your content resides).

Run Certbot again using
certbot --cert-name www.cefeel.com -d cefeel.com,www.cefeel.com
This will add the non-www domain to your cert.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.