I need to upgrade quick certbot ACMEv1 -> ACMEv2

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: abc.abc.fi

I ran this command:certbot certonly -d abc.abc.fi --keep-until-expiring --webroot --webroot-path="/var/www/html" --renew-hook "service postfix reload" --renew-hook "service apache2 restart" --renew-hook "service webmin restart"

It produced this output:An unexpected error occurred:
The server experienced an internal error :: ACMEv1 is deprecated and you can no longer get certificates from this endpoint. Please use the ACMEv2 endpoint, you may need to update your ACME client software to do so. Visit End of Life Plan for ACMEv1 - #27 by jillian for more information.
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): I use only this on mail server Imap and posftfix mail server

The operating system my web server runs on is (include version): Ubuntu 14.04.5 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.17.0

I have tried next commands:

sudo apt update
sudo apt install software-properties-common
sudo add-apt-repository universe
sudo add-apt-repository ppa:certbot/certbot
sudo apt install --only-upgrade certbot

--> certbot is already the newest version.

But I beleive that my ubuntu is so old that I cannot update the repository. So is there any other way to upgrade certbot? In two months we will upgrade this server to a new one.

Could someone help me?

1 Like

There's some information about upgrading certbot in general in this thread:

But I don't know if there's much there that will help with an Ubuntu that old. If that OS is new enough to support snap, you can install Certbot through snap, but I don't know if that'll work for you.

The general advice used in these cases (other than to upgrade the server, which you say you're working on) is to switch to a different ACME client, such as one of the shell-script or go based ones, since they have the fewest dependencies and can generally just be copied onto the server and run:

Another option, if you have access to DNS for the zone, is that you could also run certbot on some other newer system in manual dns-challenge mode, get the certificate & private key there, and then securely copy them over the existing files on your old server. Being a manual process you'd need to repeat it every couple months, but if you're decommissioning the server is a couple months it might get you going for now. I don't know as that'd really be easier than switching to a new client on that existing system, though.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.