I have mixed up two certificates. One for my subdomain one for my actual domain. Need help to fix

Removed information about server.

Please show the configuration file(s) for :80 and :443

The “server_name” only appears in the :80 section
Repeat the “server_name” within the :443 section.
All HTTPS connections are going to the “default”.

1 Like

server {
listen 80;
listen [::]:80;
server_name domain.tld sub1.domain.tld sub2.domain.tld;
return 301 https://$server_name$request_uri;
server {
listen 443 ssl;
listen [::]:443 ssl;
server_name domain.tld sub1.domain.tld sub2.domain.tld;
include snippets/ssl-domain.tld.conf;
include snippets/ssl-params.conf;
root /home/www_homepage/www/html;
index index.html;

Thank you so much, that fixed the errors. Everything works great.

I really appreciate it the time you spent and how quickly your responded.

You are very welcome.
Mark it a solved.

1 Like

It would really be nice if people wouldn’t try to delete their entire threads after problems are solved, because part of the benefit of the forum is letting other people see what the problems and solutions are.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.