I domain was blocked to receive LET"S Encrypt SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: royalcrowncabinets.ca

I ran this command:

It produced this output:

My web server is (include version): plesk

The operating system my web server runs on is (include version): Debian

My hosting provider, if applicable, is:

I can log in to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi there,
When I was trying to install the Let’s ENCRYPT SSL for some reason did not installed and I installed again and again until I lost the chance to install an Let’s Encrypt SSL. I fixed the problem on my server now and I would need your help to delete my domain to be banned from your SSL certification.
Please help me out to clear me from this list:https://crt.sh/?q=royalcrowncabinets.ca
in order to be able to install your SSL to my server.
Do I need to myself? In case I need to do something myself please let me know
Thank you

1 Like

We need to know the actual error message. (Nevermind, you’re ratelimited)

You currently have 24 valid certificates for your domain, with different combinations of hosts and two different CAs. You can use any/most of them if you have them saved somewhere.

I assume you want to use the cert for royalcrowncabinets.ca, *.royalcrowncabinets.ca, you just have to install it. – you can’t generate another for a week~3 days.

1 Like

Thank you for your reply.
This is the error that I got: https://prnt.sc/rl075s
What SHOULD I DO ?
Please help me.

1 Like

Hi @geomihut

read the link shared in the error message.

You have created a lot of certificates. So that part has worked. Now install one of these.

1 Like

I am working to install a new server and by mistake I installed the certificates.
Is there a way to delete the history from your server.
How long do I need to wait to not be registered on your serrver with my domain
Thank you

1 Like

The rate limits page tells you. In this case, I also told you: 3 days to 1 week (now 2 days, probably)

1 Like

You asked the Let’s Encrypt servers to do some work for you, they did, and then you threw away the result. You did this five times within the past week four days. So no, the work’s already been done; it isn’t possible to retroactively not do it. If you don’t have a way of using one of the five certs you’ve already recently created (and the certs are public; the only thing you’d need is the private key), wait until a week from the time the first was created, and you’ll be able to make another one. In the meantime, if you’re testing, you should be using the testing environment.

1 Like