I cannot see my site in browser

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://cabare.co.ua

I ran this command:

It produced this output:

My web server is (include version): Apache/2.4.7

The operating system my web server runs on is (include version): Ubuntu 14.04

My hosting provider, if applicable, is: Scaleway.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no - I have VPS.


I have VPS where my 10+ sites are hosted.

Almost one year ago I tried Letsencrypt certificate using Certbot, but all my sites were chained to one certificate. I tried to solve that problem by editing .conf-files in /etc/apache2/sites-available folder. After editing the files, which belong to the site cabare.co.ua - cabare.co.ua.conf and cabare.co.ua-le-ssl.conf I encountered a problem - the browsers stopped to demonstrate this site:

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

What should I do to solve this problem? I can demonstrate here the files cabare.co.ua.conf and cabare.co.ua-le-ssl.conf.

After all, I divided the connection of all my sites to the one certificate - I created the certificates to each one and rechained sites to their certificates.

It seems that you are redirecting HTTP to HTTPS and HTTPS to HTTP, creating an infinite loop of redirects. So you need to stop redirecting HTTPS to HTTP, so that you are only redirecting HTTP to HTTPS.

If you need help doing that, please do post those configuration files here.

1 Like
<VirtualHost *:80>
    ServerName cabare.co.ua

    ErrorLog "/srv/www/cabare.co.ua/logs/error.txt"
    CustomLog "/srv/www/cabare.co.ua/logs/access.txt" common
    DocumentRoot "/srv/www/cabare.co.ua/httpdocs"

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteCond %{SERVER_NAME} www.cabare.co.ua
    RewriteRule (.*) https://cabare.co.ua%{REQUEST_URI} [R=301,L]
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
<IfModule mod_ssl.c>
    <VirtualHost *:443>
        ServerName cabare.co.ua
        ErrorLog "/srv/www/cabare.co.ua/logs/error.log"
        CustomLog "/srv/www/cabare.co.ua/logs/access.log" common
        DocumentRoot "/srv/www/cabare.co.ua/httpdocs"
        <Directory "/srv/www/cabare.co.ua/httpdocs">
            DirectoryIndex index.php index.html
            Options FollowSymLinks
            Options -Indexes
            AllowOverride All
            Order deny,allow
            Allow from all
        Require all granted
    Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/cabare.co.ua-0001/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/cabare.co.ua-0001/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateChainFile /etc/letsencrypt/live/cabare.co.ua-0001/chain.pem


Okay, so it’s clear that your HTTP site is redirecting to HTTPS (which is good), but it’s not clear from those files why your HTTPS site is redirecting to HTTP. It doesn’t seem to be because of anything directly in that configuration, so it’s probably elsewhere. My guess would be either it’s a Redirect or RewriteRule in a .htaccess file in /srv/www/cabare.co.ua/httpdocs, or an application such as Wordpress that’s configured to think it’s supposed to be on HTTP and redirect when it’s not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.