Https connection problem on local network

The thing is that when I turn off AVG the problem still maintains : image
On the other hand if I add local IP address of server and the public domain to the hosts file it works fine. But this will be troublesome because every time I move outside of my network with my laptop I would have to edit this file. The question is if I can somehow determine whether my laptop should use the entry from the hosts file or just the public domain. ( or configure in some other way )

it looks like that’s routers config page, and it doesn’t support hairpin NAT.
it maybe able work properly if you move your router config page to some other port?

Do you mean to move my ISP router’s IP address to some other address?

no, the port of your router’s control page,
try enter the site ignore cert warning I’d expect a page for your router setting?
google funbox2 g6 -> found a model of router

Now it’s another certificate.

Looks like the wrong host answers.

1 Like

After ignoring the error there is my nextcloud server so I guess it is mapped correctly.

Oh, actually using the public domain I cannot skip the error :frowning:


But in case of using local IP of server after skipping I get the right page.

  • when using other browser (in that case edge) it gets me without any errors to router config site as you said.

Do you have any internal system that is capable of running DNS?
[a simple Raspberry Pi can do the trick]

Can you modify the “DNS settings” in the ISP router?
[if not, you can manually still specify the DNS IPs to use]

I am afraid only the server itself (Ubuntu 18.04).

The only thing I can do is add DNS to all the devices in the network but the problem is that if I try to add in my case anton.bounceme.net, it won’t go. I think the reason is that the DNS should not contain dots at all because otherwise router wont accept it.
I also got a DNS Ipv4 address and an alternative one but I am not able to change them and I dont know what they can be used for :frowning:

Ubuntu 18.04 can run DNS services (like: BIND).

1 Like

Do you tend to have some newbie tutorial how to establish one? As I said I am quite new to this subject

1 Like

I believe I found out that it is impossible to make any modifications. My ISP provider does not support modification of DNS server as well as it cannot be switched into bridged mode (so the hairpin solution wont apply). So I guess I am stuck with typing local address every time I want to access my server. Is there any way to obtain a certificate for local address so it won’t ask me to skip the warning?

Does buying a router not a choices? Does it do pppoe for uplink?

You could make two batch files:

  • One that updates the hosts file to resolve the server name to its’ local (LAN) IP.
  • One that reverts to the unmodified version.

I could buy a router but then I read that my ISP restricts the usage of other routers + it would be hard/impossible to configure my satelite TV properly :frowning:

That is one way to do it. Thanks for the idea.

1 Like

Anyway guys, I think it would stay as it is, just connecting using local IP and skipping the warning. Thanks you a lot for your effort and sorry for the missunderstandings. As I said I am a newbie but now I sort of get what is going on.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.