Http access only through port 8585


#1

I’ve been given a VPS which can’t use 80 and 443 externally so they use 8585 for HTTP and 8989 for HTTPS.

These are my attempts to create a cert based on some research:

$ ./letsencrypt-auto certonly --renew-by-default --webroot -w /srv/frontend -d domain.com
$ ./letsencrypt-auto certonly --http-01-port 8585 --renew-by-default --webroot -w /srv/frontend -d domain.com
$ ./letsencrypt-auto certonly -a manual -d domain.com --http-01-port 8585

Result:

- The following errors were reported by the server:
   Domain: domain.com
   Type:   connection
   Detail: Could not connect to http://domain.com/.well-known
   /acme-challenge/r1Wb4Wnc6...

Any help?


Updating cert but server is not in default port 80
#2

The http-01 challenge has to be done on port 80, the options are for when there’s a proxy or similar involved. Your only option is to use a client that supports the dns-01 challenge.


#3

You would have to complete the dns-01 challenge.


#4

How do I use dns-01?


#5

My understanding is the official client doesn’t support DNS authentication for now, so you should try one of the bash clients (e.g. Neilpang’s acme.sh client).


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.