How to recovery losts https keys


#1

my server machine is crashed and its erase every thing on machine so i lost my ssl keys
When i am trying to re generate new key its show an error message and see log files /var/share/letsencrypits


#2

Unless you made a backup, there is no way to recover lost keys. You will just need to request a new certificate.

What does the log say? What command did you run?


#3

Request a new cert is very easy task (dont meet rate limit)
So, what does the log say?


#4

thanks for giving replay to my question

When i am trying to regenerate the new ssl certificates its below error
message
Please find the attached screen shot


#5

plz show result of
cat /var/log/letsencrypt


#6

and the log file having following data

2017-02-16 09:31:52,992:DEBUG:letsencrypt.cli:Root logging level set at 30
2017-02-16 09:31:52,993:INFO:letsencrypt.cli:Saving debug log to
/var/log/letsencrypt/letsencrypt.log
2017-02-16 09:31:52,994:DEBUG:letsencrypt.cli:letsencrypt version: 0.4.1
2017-02-16 09:31:52,994:DEBUG:letsencrypt.cli:Arguments: [’–apache’]
2017-02-16 09:31:52,995:DEBUG:letsencrypt.cli:Discovered plugins:
PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)
2017-02-16 09:31:53,000:DEBUG:letsencrypt.cli:Requested authenticator
apache and installer apache
2017-02-16 09:31:53,372:DEBUG:letsencrypt.display.ops:Single candidate
plugin: * apache
Description: Apache Web Server - Alpha
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = letsencrypt_apache.configurator:ApacheConfigurator
Initialized: <letsencrypt_apache.configurator.ApacheConfigurator object at
0x7f049039fcd0>
Prep: True
2017-02-16 09:31:53,373:DEBUG:letsencrypt.cli:Selected authenticator
<letsencrypt_apache.configurator.ApacheConfigurator object at
0x7f049039fcd0> and installer
<letsencrypt_apache.configurator.ApacheConfigurator object at
0x7f049039fcd0>
2017-02-16 09:32:25,517:DEBUG:root:Sending GET request to
https://acme-v01.api.letsencrypt.org/directory. args: (), kwargs: {}
2017-02-16
09:32:25,535:INFO:requests.packages.urllib3.connectionpool:Starting new
HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-02-16 09:32:25,832:DEBUG:letsencrypt.cli:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/letsencrypt”, line 9, in
load_entry_point(‘letsencrypt==0.4.1’, ‘console_scripts’,
‘letsencrypt’)()
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 1986, in
main
return config.func(config, plugins)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 660, in
run
le_client = _init_le_client(config, authenticator, installer)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 206, in
_init_le_client
acc, acme = _determine_account(config)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 191, in
_determine_account
config, account_storage, tos_cb=_tos_cb)
File “/usr/lib/python2.7/dist-packages/letsencrypt/client.py”, line 116,
in register
acme = acme_from_config_key(config, key)
File “/usr/lib/python2.7/dist-packages/letsencrypt/client.py”, line 41,
in acme_from_config_key
return acme_client.Client(config.server, key=key, net=net)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 63, in
init
self.net.get(directory).json())
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 627, in get
self._send_request(‘GET’, url, **kwargs), content_type=content_type)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 609, in
_send_request
response = requests.request(method, url, *args, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/api.py”, line 53, in
request
return session.request(method=method, url=url, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/sessions.py”, line 468,
in request
resp = self.send(prep, **send_kwargs)
File “/usr/lib/python2.7/dist-packages/requests/sessions.py”, line 576,
in send
r = adapter.send(request, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/adapters.py”, line 447,
in send
raise SSLError(e, request=request)
SSLError: [Errno 2] No such file or directory

plese give exact soloutions for me


#7

thank you for repaly
root@colourssoftware:/var/log/letsencrypt# cat letsencrypt.log shows below message

2017-02-16 09:31:52,992:DEBUG:letsencrypt.cli:Root logging level set at 30
2017-02-16 09:31:52,993:INFO:letsencrypt.cli:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2017-02-16 09:31:52,994:DEBUG:letsencrypt.cli:letsencrypt version: 0.4.1
2017-02-16 09:31:52,994:DEBUG:letsencrypt.cli:Arguments: [’–apache’]
2017-02-16 09:31:52,995:DEBUG:letsencrypt.cli:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)
2017-02-16 09:31:53,000:DEBUG:letsencrypt.cli:Requested authenticator apache and installer apache
2017-02-16 09:31:53,372:DEBUG:letsencrypt.display.ops:Single candidate plugin: * apache
Description: Apache Web Server - Alpha
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: apache = letsencrypt_apache.configurator:ApacheConfigurator
Initialized: <letsencrypt_apache.configurator.ApacheConfigurator object at 0x7f049039fcd0>
Prep: True
2017-02-16 09:31:53,373:DEBUG:letsencrypt.cli:Selected authenticator <letsencrypt_apache.configurator.ApacheConfigurator object at 0x7f049039fcd0> and installer <letsencrypt_apache.configurator.ApacheConfigurator object at 0x7f049039fcd0>
2017-02-16 09:32:25,517:DEBUG:root:Sending GET request to https://acme-v01.api.letsencrypt.org/directory. args: (), kwargs: {}
2017-02-16 09:32:25,535:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2017-02-16 09:32:25,832:DEBUG:letsencrypt.cli:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/letsencrypt”, line 9, in
load_entry_point(‘letsencrypt==0.4.1’, ‘console_scripts’, ‘letsencrypt’)()
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 1986, in main
return config.func(config, plugins)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 660, in run
le_client = _init_le_client(config, authenticator, installer)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 206, in _init_le_client
acc, acme = _determine_account(config)
File “/usr/lib/python2.7/dist-packages/letsencrypt/cli.py”, line 191, in _determine_account
config, account_storage, tos_cb=_tos_cb)
File “/usr/lib/python2.7/dist-packages/letsencrypt/client.py”, line 116, in register
acme = acme_from_config_key(config, key)
File “/usr/lib/python2.7/dist-packages/letsencrypt/client.py”, line 41, in acme_from_config_key
return acme_client.Client(config.server, key=key, net=net)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 63, in init
self.net.get(directory).json())
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 627, in get
self._send_request(‘GET’, url, **kwargs), content_type=content_type)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 609, in _send_request
response = requests.request(method, url, *args, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/api.py”, line 53, in request
return session.request(method=method, url=url, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/sessions.py”, line 468, in request
resp = self.send(prep, **send_kwargs)
File “/usr/lib/python2.7/dist-packages/requests/sessions.py”, line 576, in send
r = adapter.send(request, **kwargs)
File “/usr/lib/python2.7/dist-packages/requests/adapters.py”, line 447, in send
raise SSLError(e, request=request)
SSLError: [Errno 2] No such file or directory


#8

Since you opened another thread to get help with generating new certificates I’m going to close this one.

Thanks!


#9