How to make Certbot-auto to use python 2.7?



I ran this command:certbot-auto renew

It produced this output:DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of cryptography will drop support for Python 2.6

My operating system is (include version): Centos 6.7

My web server is (include version): Apache 2.4

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I just installed certbot-auto and successfully ran it, the website is ok with https, like everybody i followed the tutorial on how to renew, for the sake of trying it, and this warning message popped up. So I installed python 2.7 and created an Alias to the newest python, when i run which python, it return 2.7.
But when i run certbot-auto renew, it keeps saying the python 2.6 is deprecated.
How to make certbot to use python 2.7? When will letsencrypt drop support of python2.6?


in Centos 6 it requires Python 2.6 for much of the OS, so it can get a bit messy :wink:

Have a look at Redhat / CentOS 6.x users need python 2.7

or, you can use one of the alternate clients which don’t have the same dependencies ( such as the pure bash clients)


thank you for the link, it seems says if you don’t mind the warning message everything will be all right, certbot-auto will continue to work with python 2.6


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.