How to change name issuer on centos 7

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=office.aaptechmil.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
office.aaptechmil.com

I ran this command:
sudo certbot certonly --apache

It produced this output:

Obtaining a new certificate
Performing the following challenges:
http-01 challenge for office.aaptechmil.com
Cleaning up challenges
Unable to find a virtual host listening on port 80 which is currently needed for Certbot to prove to the CA that you control your domain. Please add a virtual host for port 80.

My web server is (include version):
apache 2.4

The operating system my web server runs on is (include version):
centos 7

My hosting provider, if applicable, is:
virtual private server

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 1.0.0

I don’t think you can use both certonly and --apche in the same command line.
I don’t really understand the topic problem/request: “How to change name issuer on centos 7
It seems that you have not made a virtual host for the cert name requested:

You may need to take a few steps back and begin at the very beginning…
“How to serve my first website in Apache”

im try and configure my ssl in vhost.but im access with https website is blank

in my setting sites-available
<VirtualHost *:80>
ServerName www.office.aaptechmil.com
ServerAlias office.aaptechmil.com
DocumentRoot /var/www/html/office.aaptechmil.com

should i edit in ssl.conf?

Try letting certbot do it for you:
sudo certbot --apache -d office.aaptechmil.com -d www.office.aaptechmil.com

i try and same get problem website cannot show,
and i edit my office.aaptechmil.com.conf

<VirtualHost *:80>
    ServerName www.office.aaptechmil.com
    ServerAlias office.aaptechmil.com
     DocumentRoot /var/www/html/office.aaptechmil.com
RewriteEngine on
RewriteCond %{SERVER_NAME} =www.office.aaptechmil.com [OR]
RewriteCond %{SERVER_NAME} =office.aaptechmil.com
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

and i add below

<VirtualHost *:443>

        SSLEngine on
        <Directory /var/www/html/office.aaptechmil.com>
                AllowOverride All
        </Directory>

        DocumentRoot /var/www/html/office.aaptechmil.com
        ServerName office.aaptechmil.com
        ServerAlias www.office.aaptechmil.com
        Include /etc/letsencrypt/options-ssl-apache.conf


        SSLCertificateFile /etc/letsencrypt/live/office.aaptechmil.com/cert.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/office.aaptechmil.com/privk$
SSLCertificateChainFile /etc/letsencrypt/live/office.aaptechmil.com/chain.pem
</VirtualHost>

its correct ??

Not sure what that is…
But otherwise it seems correct.

Please show the output of:
certbot certificates

Found the following certs:
  Certificate Name: office.aaptechmil.com
    Domains: office.aaptechmil.com www.office.aaptechmil.com
    Expiry Date: 2020-05-19 05:49:52+00:00 (VALID: 89 days)
    Certificate Path: /etc/letsencrypt/live/office.aaptechmil.com/fullchain.pem
    Private Key Path: /etc/letsencrypt/live/office.aaptechmil.com/privkey.pem

That’s a good cert :slight_smile:

And the website looks secure:
https://www.ssllabs.com/ssltest/analyze.html?d=office.aaptechmil.com&hideResults=on&latest

You should probably disable TLSv1.1

ok thanks, this issue solve

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.