How to add certificate to a wordpress website hosted on 000webhost


#1

Please fill out the fields below so we can help you better.

My domain is: https://harjeev98.cf/

I ran this command: I really dont know anything about how to add the certificate

It produced this output: N/A

My operating system is (include version): Windows 10 Pro

My web server is (include version): erm, server is 000webhostapp

My hosting provider, if applicable, is: 000webhost.com

I can login to a root shell on my machine (yes or no, or I don’t know): i dont know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel


#2

do you have a premium subscription or a free one?


#3

Free mate, I don’t wanna pay for having 1 website running only.


#4

They don’t support SSL, but you can upgrade so they do support it? What kind of sad, short, strange answer is thát? :weary:


#5

Hi MrHarv98

Set up your site and point it to cloudflare.

Use their SSL for your site

@Osiris agreed but if it’s free you can’t really complain


#6

It’s more the choice of words I’m refefring to… :slight_smile:


#7

hey mate thanks for answer but after i have setup ssl from cloudflare domain wont resolve
screenshot of the setup in cloudflare https://cl.ly/j1kb
domain which wont resolve → harjeev98.cf


#8

Hi MrHarv98

Try pointing the www to the 000webhosting domain (test98) (like you did the tld) and this should solve the problem

You are eventually getting to harjeev98.cf but you are not retaining the HTTPS for some reason


#9

Did that and now the website works, but the formatting is all fked up


#10

Can somebody check if website is using SSL?


#11

Yes harjeev98.cf is using a cloudflare SSL cert.


#12

Thanks, doesn’t the website seem to be non formatted to you? I mean missing scripts…
Can you please give me a screenshot of how it looks to you


#13

No obvious missing scripts - see
https://shrinktheweb.snapito.io/v2/webshot/spu-ea68c8-ogi2-3cwn3bmfojjlb56e?size=800x0&screen=1024x768&url=https%3A%2F%2Fharjeev98.cf although on this link the images are missing ( they aren’t for me )


#14

Well now HTTPS works on chrome for desktop but when i open the same website in android/ios browser only HTTP is working, wtf


#15

Could be a mixed content issue where CSS resources (or scripts) are being loaded from a non-secure origin, like a different server that is only HTTP.

One resource that helps analyze problems like that is

https://www.whynopadlock.com/

It could also be a more subtle problem with certificate chains or something; if you are serving CSS or Javascript from a different domain than your main domain, and you know that it’s HTTPS, you can try analyzing the configuration of the CSS or Javascript hosting domain with

https://www.ssllabs.com/ssltest/

Hopefully, if there is indeed a configuration problem somewhere, one of those two tools will be able to identify it for you.


#16

Thanks, I’ll check sometime tomorrow , been busy lately, will let you know if there are any errors


#17

Hey, I did visit those links you gave and i got the following errors in result
CloudApp
CloudApp

Also, Yesterday my domain was down, Today it’s backup. Secondly SSL is not being forced on the domain. I’ve tried googling tons of stuff and even add some plugins in Wordpress to force HTTPS on the website. Still doesn’t work.

And now Wordpress theme editing is broken for me and my 000webhost file manager gives me a -1 error
Screenshot→ https://cl.ly/j4eH

It’s like everything works 1 day and the next day your screwed finding why it wont work
im so pissed off at this point.


#18

I’d suggest reading through the thread again from the top.

000webhost.com do not support SSL certificates, unless you upgrade (which you didn’t want to do).

The suggestion was to use cloudflare (which you did for a while), however your DNS is no longer pointing at cloudflare - hance cloudflare SSL is not being used - you are using 000webhost.com which doesn’t support https unless you upgrade.


#19

m8 then tell me why Cloudflare’s SSL worked for 1 day?


#20

I don’t know when the DNS settings were changed. It looks as if they are back now working through cloudflare as your primary DNS so I assumed you changed things back to that.