Help with certbot renew


#1

Got my first SSL cert through letsencrypt a few months ago. I thought it would auto renew but turns out it didn’t. I’m not exactly sure what I did wrong. I went back to ubuntu and tried certbot renew and am getting this error:

PluginError(‘An authentication script must be provided with --manual-auth-hook when using the manual plugin non-interactively.’,)

All answers online have been leading me nowhere, they either seem outdated or I’m not understanding them. Should I be looking to get a brand new certificate or what am I doing wrong? Could anyone here point me to the right direction?


https://dltutuapp.com/ https://9apps.ooo/ https://showbox.software/


#2

Your initial cert used a manual authentication method.
Show the renewal file at:
/etc/letsencrypt/renewal/YOUR.DOMAIN


#3

Certbot can’t automatically renew manually managed certificates. To renew it, you can run the command you used to create the certificate originally, such as “sudo certbot certonly --manual -d example.com -d www.example.com”.

Can you provide more information?

Why did you use manual mode before? Can you switch to one of the automated modes?

Are you running Certbot directly on your web server, or a different computer?


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.