Help me untangle my installation... where are these log messages coming from?

Hello, I'm getting log messages and am not sure where they are coming from.
I tried "grep -R letsencrypt /etc/cron*" and also "grep -R certbot /etc/cron*" and I cannot figure out what cron is launching that is trying to run python in this way.
I also suspect my certbot install is perhaps not functioning. But my websites are protected, so the certs I have are valid.

root@linode (var ): certbot certificates
Saving debug log to /var/log/letsencrypt/letsencrypt.log
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Found the following certs:
(all seem OK)

My domain is: richcook.net

I ran this command: I checked my email

It produced this output: I'm getting log messages that say this:

Cron root@linode python -c 'import random; import time; time.sleep(random.random() * 3600)' && /usr/local/bin/certbot-auto renew
To: Cron Daemon root@richcook.net
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Mime-Version: 1.0
Received: from linode....
Received: by linode...
Delivered-To: my email
Return-Path: root@richcook.net
X-Cron-Env: <SHELL=/bin/sh>
X-Cron-Env: <HOME=/root>
X-Cron-Env: <PATH=/usr/bin:/bin>
X-Cron-Env: <LOGNAME=root>
20210214203458.010CA81CA5@linode.richcook.net

My web server is (include version): apache. (not sure how to check version, derp derp)

The operating system my web server runs on is (include version): Debian buster

My hosting provider, if applicable, is: linode

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): nope

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

NOTE that the error in the log refers to /usr/local/bin but it's actually in /usr/bin/certbot
root@linode (var ): which certbot
*usr/bin/certbot
root@linode (var ): certbot --version
**certbot 1.12.0
**root@linode (var ): certbot-auto
**bash: certbot-auto: command not found

1 Like

Two more locations to check are the below (which are stored in /var/spool/cron/), as well as systemd timers:

crontab -l
sudo crontab -l
4 Likes

Thanks! It was in /var/spool/cron/crontab/root of course.

2 Likes