Help After Deleting a Certificate I get SSL_ERROR_RX_RECORD_TOO_LONG

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
certbot delete

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):
ubunutu 16.4

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.28.0-1+ubuntu16.04.1+certbot+4

Hi @rodericks

why do you delete a certificate? The error message


says: Your port 443 is a http port, not a https port. Same result - a check, ~~45 minutes old - - Grade Q.

So you have two options:

  • Remove the port 443 complete, create a new certificate and let Certbot create a new vHost
  • add an expired or a self signed certificate to your port 443 vHost, so that vHost has a wrong certificate, but answers.

Thank you I’ll look into that. For now I just ran certbot --rollback, and that seems to have gotten the website back up. I’ll try your solution this weekend.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.