Got Error Whlie getting SSL from

I Added these two files you can check it from here the links work fine…

Checked with an offline downloader it's the same code:

<html><body><script type="text/javascript" src="/aes.js" ></script><script>function toNumbers(d){var e=[];d.replace(/(..)/g,function(d){e.push(parseInt(d,16))});return e}function toHex(){for(var d=[],d=1==arguments.length&&arguments[0].constructor==Array?arguments[0]:arguments,e="",f=0;f<d.length;f++)e+=(16>d[f]?"0":"")+d[f].toString(16);return e.toLowerCase()}var a=toNumbers("f655ba9d09a112d4968c63579db590b4"),b=toNumbers("98344c2eee86c3994890592585b49f80"),c=toNumbers("b912174d079bc73ded9dbc958674190f");document.cookie="__test="+toHex(slowAES.decrypt(c,2,a,b))+"; expires=Thu, 31-Dec-37 23:55:55 GMT; path=/"; location.href="";</script><noscript>This site requires Javascript to work, please enable Javascript in your browser or use a browser with Javascript support</noscript></body></html>

You must deactivate that in /.well-known/acme-challenge.

I run it on my brower by putting this code in .html file extenssion but nothing will happen when i run it.

Your server doesn't send such a code.

Your server has to send something like


nothing else.

The long, random name of the file, a dot and a hash value from the Letsencrypt account.

No html, no javascript, no redirect.

It means the problem is with my browser i use chrome?
Let me check it in Firefox…

It isn't relevant which browser you use. Use an online tool or an offline downloader.

You must see something like that:

without JavaScript.

thats what i get with offline downloader

You have to upload a file with that complex name.

Not a folder. So your upload action is wrong.

And that’s not an offline downloader, that’s a local program.

Thanks Sir For Your Time…

The Conclusion is there is no solution for this problem right.
and now i am looking for some other free ssl provider so if
you know some one then please tell me and hope this issue
be completely resolved in future

it looks like your hosting provider uses cpanel and support autossl. use that instead. it may give LE or comodo ssl but it will work.

It doesn’t provide any ssl. Yeah it uses Comodo i think

May be the problem is with my domain name.


Free SSL Certificates

All iFastNet accounts come with unlimited free SSL certificates provided by Let’s Encrypt.

just ask them to how to use it.

But I am using free plan i did not buy any plan from them.
May be thats the reason my domain is without ssl.

yes, you may be in bad shape

It is not possible to use Let’s Encrypt certificates (and by extension) on InfinityFree. Let’s Encrypt verifies that you own a domain name by checking a URL on your website for a certain value. However, all InfinityFree accounts have a security system which prevents access to most automated bots and programs, and only lets valid web browsers access your website. While this is perfectly fine for website hosting, it does make the Let’s Encrypt verification tool unable to check whether your own the domain.

Let’s Encrypt also offers TXT record validation. However, you cannot set TXT records on domains hosted by InfinityFree. If you are using your own nameservers, you may be able to set TXT records and get your Let’s Encrypt certificate. These certificates can be installed on InfinityFree without any problems.

… (comodo ad)


You might be better off looking for a different free hosting provider. There are other free certificate providers, but they mostly use the same technology that Let's Encrypt does!

This anti-bot Javascript was presumably put in place by the hosting provider. If they won't help you disable it because you're not paying them, you might want to pay them, or else use a different provider that doesn't have this restriction.

You could look at this thread to find web hosts who support Let's Encrypt:

(Some of them may have free-of-charge hosting options that still include support for Let's Encrypt.)

Wow, the resource that @orangepizza found seems to answer the question pretty definitively! Thanks for finding that.

1 Like

Oh That’s mean Infinityfree not Support the lets Encrypt.
Thanks for your Support @orangepizza and @schoen.


The key part here is that it is possible as long as "you are using your own nameservers". You don't have to stick to the nameservers given to you by your domain registrar or hoster - you can switch to any free "DNS Hosting Provider" and use DNS verification. Alternatively, you can switch your hoster or even get a VPS with unrestricted access to any settings - probably for the same or even lower price ( is a good starting point to look for those).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.