Golang server problem

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot certonly --webroot --webroot-path /tmp/letsencrypt/ --dry-run -d pressurewash.io

It produced this output:

  • The following errors were reported by the server:

    Domain: pressurewash.io
    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
golang standalone

The operating system my web server runs on is (include version):
centos7 latest
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Extra information: I was having trouble getting certbot to work for me, and so i searched and found this tutorial. I expected it to work since i can readily access pressurewash.io when running the backend, and i figured this would resolve some of my port 80 problems. Sadly, no, this is the same error i got earlier. I followed this guide exactly, and it still has timeout error.
📄 Adding webroot support to your existing Go/Golang server

Are you sure your AT&T service allows you to forward ports? Have you forwarded port 80 to the machine running your webserver?

Your server is not accessible from the internet, and the error from Certbot reflects that.

1 Like

Thanks, this seems to be what the problem is. I havent solved it yet, but I can confirm that my router hasnt enabled this device on the public IP. Thanks so much its been so long since ive setup the last public ip address i forgot i needed to do this. Cheers.

1 Like

I didnt want to bump but i couldnt find an edit. The problem I faced was that my virtual machine host changed in the last few months and I forgot to reinitialize network bridging. Thanks to @_az for putting me on the right path to solving this.


Hi @cmshnrblu

use the three ..., then a pencil is shown.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.