Godaddy - ssh certification for subdomain - help

Original Query

Dear Niel
I am again stuck at the error today. Not able to verify 99anchors.dev.new.citykites.com

below is the full error log
\ sachinmandalia@p3plcpnl0887 [~]$ acme.sh --issue -d dev.new.citykites.com -w public_html -d 99anchors.com -w public_html/99anchors --force
[Sat Sep 9 15:40:18 MST 2017] Multi domain=‘DNS:99anchors.com’
[Sat Sep 9 15:40:18 MST 2017] Getting domain auth token for each domain
[Sat Sep 9 15:40:18 MST 2017] Getting webroot for domain=‘dev.new.citykites.com
[Sat Sep 9 15:40:18 MST 2017] Getting new-authz for domain=‘dev.new.citykites.com
[Sat Sep 9 15:40:19 MST 2017] The new-authz request is ok.
[Sat Sep 9 15:40:19 MST 2017] Getting webroot for domain=‘99anchors.com
[Sat Sep 9 15:40:19 MST 2017] Getting new-authz for domain=‘99anchors.com
[Sat Sep 9 15:40:19 MST 2017] The new-authz request is ok.
[Sat Sep 9 15:40:19 MST 2017] dev.new.citykites.com is already verified, skip http-01.
[Sat Sep 9 15:40:19 MST 2017] 99anchors.com is already verified, skip http-01.
[Sat Sep 9 15:40:19 MST 2017] Verify finished, start to sign.
[Sat Sep 9 15:40:20 MST 2017] Sign failed: “detail”:“Error creating new cert :: too many certificates already issued for exact set of domains: 99anchors.com,dev.new.citykites.com
[Sat Sep 9 15:40:20 MST 2017] Please add ‘–debug’ or ‘–log’ to check more details.
[Sat Sep 9 15:40:20 MST 2017] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh
sachinmandalia@p3plcpnl0887 [~]$ acme.sh --issue -d 99anchors.dev.new.citykites.com -w public_html/99anchors
[Sat Sep 9 15:51:32 MST 2017] Single domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:32 MST 2017] Getting domain auth token for each domain
[Sat Sep 9 15:51:32 MST 2017] Getting webroot for domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:32 MST 2017] Getting new-authz for domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:33 MST 2017] The new-authz request is ok.
[Sat Sep 9 15:51:33 MST 2017] Verifying:99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:37 MST 2017] 99anchors.dev.new.citykites.com:Verify error:DNS problem: NXDOMAIN looking up A for 99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:37 MST 2017] Please add ‘–debug’ or ‘–log’ to check more details.
[Sat Sep 9 15:51:37 MST 2017] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh
sachinmandalia@p3plcpnl0887 [~]$ acme.sh --issue -d 99anchors.dev.new.citykites.com -w public_html/99anchors --debug
[Sat Sep 9 15:51:52 MST 2017] Lets find script dir.
[Sat Sep 9 15:51:52 MST 2017] SCRIPT=’/home/sachinmandalia/.acme.sh/acme.sh’
[Sat Sep 9 15:51:52 MST 2017] _script=’/home/sachinmandalia/.acme.sh/acme.sh’
[Sat Sep 9 15:51:52 MST 2017] _script_home=’/home/sachinmandalia/.acme.sh’
[Sat Sep 9 15:51:52 MST 2017] Using config home:/home/sachinmandalia/.acme.sh
https://github.com/Neilpang/acme.sh
v2.7.4
[Sat Sep 9 15:51:52 MST 2017] Using config home:/home/sachinmandalia/.acme.sh
[Sat Sep 9 15:51:52 MST 2017] DOMAIN_PATH=’/home/sachinmandalia/.acme.sh/99anchors.dev.new.citykites.com’
[Sat Sep 9 15:51:52 MST 2017] Using ACME_DIRECTORY: https://acme-v01.api.letsencrypt.org/directory
[Sat Sep 9 15:51:52 MST 2017] _init api for server: https://acme-v01.api.letsencrypt.org/directory
[Sat Sep 9 15:51:52 MST 2017] ACME_KEY_CHANGE=‘https://acme-v01.api.letsencrypt.org/acme/key-change
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_AUTHZ=‘https://acme-v01.api.letsencrypt.org/acme/new-authz
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_ORDER=‘https://acme-v01.api.letsencrypt.org/acme/new-cert
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_ACCOUNT=‘https://acme-v01.api.letsencrypt.org/acme/new-reg
[Sat Sep 9 15:51:52 MST 2017] ACME_REVOKE_CERT=‘https://acme-v01.api.letsencrypt.org/acme/revoke-cert
[Sat Sep 9 15:51:52 MST 2017] Le_NextRenewTime
[Sat Sep 9 15:51:52 MST 2017] _on_before_issue
[Sat Sep 9 15:51:52 MST 2017] Le_LocalAddress
[Sat Sep 9 15:51:52 MST 2017] Check for domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:52 MST 2017] _currentRoot=‘public_html/99anchors’
[Sat Sep 9 15:51:52 MST 2017] _saved_account_key_hash is not changed, skip register account.
[Sat Sep 9 15:51:52 MST 2017] Read key length:
[Sat Sep 9 15:51:52 MST 2017] _createcsr
[Sat Sep 9 15:51:52 MST 2017] Single domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:52 MST 2017] Getting domain auth token for each domain
[Sat Sep 9 15:51:52 MST 2017] Getting webroot for domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:52 MST 2017] _w=‘public_html/99anchors’
[Sat Sep 9 15:51:52 MST 2017] _currentRoot=‘public_html/99anchors’
[Sat Sep 9 15:51:52 MST 2017] Getting new-authz for domain=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:52 MST 2017] _init api for server: https://acme-v01.api.letsencrypt.org/directory
[Sat Sep 9 15:51:52 MST 2017] ACME_KEY_CHANGE=‘https://acme-v01.api.letsencrypt.org/acme/key-change
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_AUTHZ=‘https://acme-v01.api.letsencrypt.org/acme/new-authz
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_ORDER=‘https://acme-v01.api.letsencrypt.org/acme/new-cert
[Sat Sep 9 15:51:52 MST 2017] ACME_NEW_ACCOUNT=‘https://acme-v01.api.letsencrypt.org/acme/new-reg
[Sat Sep 9 15:51:52 MST 2017] ACME_REVOKE_CERT=‘https://acme-v01.api.letsencrypt.org/acme/revoke-cert
[Sat Sep 9 15:51:52 MST 2017] Try new-authz for the 0 time.
[Sat Sep 9 15:51:52 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/new-authz
[Sat Sep 9 15:51:52 MST 2017] payload=’{“resource”: “new-authz”, “identifier”: {“type”: “dns”, “value”: “99anchors.dev.new.citykites.com”}}’
[Sat Sep 9 15:51:52 MST 2017] RSA key
[Sat Sep 9 15:51:52 MST 2017] GET
[Sat Sep 9 15:51:52 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/directory
[Sat Sep 9 15:51:52 MST 2017] timeout
[Sat Sep 9 15:51:52 MST 2017] _CURL=‘curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header ‘
[Sat Sep 9 15:51:52 MST 2017] ret=‘0’
[Sat Sep 9 15:51:52 MST 2017] POST
[Sat Sep 9 15:51:52 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/new-authz
[Sat Sep 9 15:51:52 MST 2017] _CURL=‘curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header ‘
[Sat Sep 9 15:51:53 MST 2017] _ret=‘0’
[Sat Sep 9 15:51:53 MST 2017] code=‘201’
[Sat Sep 9 15:51:53 MST 2017] The new-authz request is ok.
[Sat Sep 9 15:51:53 MST 2017] entry=’“type”:“http-01”,“status”:“pending”,“uri”:“https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013",“token”:"cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4”’
[Sat Sep 9 15:51:53 MST 2017] token=‘cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4’
[Sat Sep 9 15:51:53 MST 2017] uri=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:53 MST 2017] keyauthorization=‘cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8’
[Sat Sep 9 15:51:53 MST 2017] dvlist=‘99anchors.dev.new.citykites.com#cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8#https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013#http-01#public_html/99anchors
[Sat Sep 9 15:51:53 MST 2017] vlist=‘99anchors.dev.new.citykites.com#cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8#https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013#http-01#public_html/99anchors,’
[Sat Sep 9 15:51:53 MST 2017] ok, let’s start to verify
[Sat Sep 9 15:51:53 MST 2017] Verifying:99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:53 MST 2017] d=‘99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:53 MST 2017] keyauthorization=‘cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8’
[Sat Sep 9 15:51:53 MST 2017] uri=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:53 MST 2017] _currentRoot=‘public_html/99anchors’
[Sat Sep 9 15:51:53 MST 2017] wellknown_path=‘public_html/99anchors/.well-known/acme-challenge’
[Sat Sep 9 15:51:53 MST 2017] writing token:cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4 to public_html/99anchors/.well-known/acme-challenge/cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4
[Sat Sep 9 15:51:53 MST 2017] Changing owner/group of .well-known to sachinmandalia:nobody
[Sat Sep 9 15:51:53 MST 2017] chown: changing ownership of public_html/99anchors/.well-known/acme-challenge/cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4': Operation not permitted chown: changing ownership ofpublic_html/99anchors/.well-known/acme-challenge/1HvhLuD8vx3Acis-ILzw_RYvNeKrdas8AHkaAnYWmLA’: Operation not permitted
chown: changing ownership of public_html/99anchors/.well-known/acme-challenge': Operation not permitted chown: changing ownership ofpublic_html/99anchors/.well-known’: Operation not permitted
[Sat Sep 9 15:51:53 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:53 MST 2017] payload=’{“resource”: “challenge”, “keyAuthorization”: “cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8”}’
[Sat Sep 9 15:51:53 MST 2017] POST
[Sat Sep 9 15:51:53 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:53 MST 2017] _CURL='curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header '
[Sat Sep 9 15:51:54 MST 2017] _ret=‘0’
[Sat Sep 9 15:51:54 MST 2017] code=‘202’
[Sat Sep 9 15:51:54 MST 2017] sleep 2 secs to verify
[Sat Sep 9 15:51:56 MST 2017] checking
[Sat Sep 9 15:51:56 MST 2017] GET
[Sat Sep 9 15:51:56 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:56 MST 2017] timeout
[Sat Sep 9 15:51:56 MST 2017] _CURL=‘curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header ‘
[Sat Sep 9 15:51:56 MST 2017] ret=‘0’
[Sat Sep 9 15:51:57 MST 2017] 99anchors.dev.new.citykites.com:Verify error:DNS problem: NXDOMAIN looking up A for 99anchors.dev.new.citykites.com
[Sat Sep 9 15:51:57 MST 2017] Debug: get token url.
[Sat Sep 9 15:51:57 MST 2017] GET
[Sat Sep 9 15:51:57 MST 2017] url=‘http://99anchors.dev.new.citykites.com/.well-known/acme-challenge/cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4
[Sat Sep 9 15:51:57 MST 2017] timeout=‘1’
[Sat Sep 9 15:51:57 MST 2017] _CURL=‘curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header --connect-timeout 1’
[Sat Sep 9 15:51:57 MST 2017] Please refer to https://curl.haxx.se/libcurl/c/libcurl-errors.html for error code: 6
[Sat Sep 9 15:51:57 MST 2017] ret=‘6’
[Sat Sep 9 15:51:57 MST 2017] Debugging, skip removing: public_html/99anchors/.well-known/acme-challenge/cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4
[Sat Sep 9 15:51:57 MST 2017] pid
[Sat Sep 9 15:51:57 MST 2017] No need to restore nginx, skip.
[Sat Sep 9 15:51:57 MST 2017] _clearupdns
[Sat Sep 9 15:51:57 MST 2017] skip dns.
[Sat Sep 9 15:51:57 MST 2017] _on_issue_err
[Sat Sep 9 15:51:57 MST 2017] Please add ‘–debug’ or ‘–log’ to check more details.
[Sat Sep 9 15:51:57 MST 2017] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh
[Sat Sep 9 15:51:57 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:57 MST 2017] payload=’{“resource”: “challenge”, “keyAuthorization”: “cwMj4iS3ugNcWf4rjJILz422MZRUoaTLd__cslI0bu4.y4n16hAf3Jup8Ss6NqjU9tSmStrYj_di-dEBz1DjKC8”}’
[Sat Sep 9 15:51:57 MST 2017] POST
[Sat Sep 9 15:51:57 MST 2017] url=‘https://acme-v01.api.letsencrypt.org/acme/challenge/64TIidh86x3VP6i-JLqiEpU76oTz0Tl-BGqrY0f-XtE/1949458013
[Sat Sep 9 15:51:57 MST 2017] _CURL='curl -L --silent --dump-header /home/sachinmandalia/.acme.sh/http.header '
[Sat Sep 9 15:51:57 MST 2017] _ret=‘0’
[Sat Sep 9 15:51:57 MST 2017] code=‘400’
[Sat Sep 9 15:51:57 MST 2017] socat doesn’t exists.
[Sat Sep 9 15:51:57 MST 2017] Diagnosis versions:
openssl:openssl
OpenSSL 1.0.1e-fips 11 Feb 2013
apache:
apache doesn’t exists.
nginx:
nginx doesn’t exists.
socat:

too many certificates already issued for exact set of domains
Means just that - too many already issued.
The certs are being issued.
See: crt.sh | 207165560
You need to look into where the certs are being placed and how to use them.
And also understand what the "--force" parameter does.

but if you can see original post, here there are 3 domains,
Original Query click here

99anchors.com, dev.new.citykites.com and 99anchors.dev.new.citykites.com

i have verified or installed certs for 99anchors.com and dev.new.citykites.com
but cant do it for the last one
sachinmandalia@p3plcpnl0887 [~]$ acme.sh --issue -d 99anchors.dev.new.citykites.com -w public_html/99anchors
[Sun Sep 10 03:59:16 MST 2017] Single domain=‘99anchors.dev.new.citykites.com
[Sun Sep 10 03:59:16 MST 2017] Getting domain auth token for each domain
[Sun Sep 10 03:59:16 MST 2017] Getting webroot for domain=‘99anchors.dev.new.citykites.com
[Sun Sep 10 03:59:16 MST 2017] Getting new-authz for domain=‘99anchors.dev.new.citykites.com
[Sun Sep 10 03:59:20 MST 2017] The new-authz request is ok.
[Sun Sep 10 03:59:20 MST 2017] Verifying:99anchors.dev.new.citykites.com
[Sun Sep 10 03:59:24 MST 2017] 99anchors.dev.new.citykites.com:Verify error:DNS problem: NXDOMAIN looking up A for 99anchors.dev.new.citykites.com
[Sun Sep 10 03:59:24 MST 2017] Please add ‘–debug’ or ‘–log’ to check more details.
[Sun Sep 10 03:59:24 MST 2017] See: https://github.com/Neilpang/acme.sh/wiki/How-to-debug-acme.sh

There is no ip defined for 99anchors.dev.new.citykites.com

ow but I did like twice without this issue… pity that I didnt notice the steps… but now what shall I do?

@sachy123, well, you need to create an A record for your domain 99anchors.dev.new.citykites.com on your DNS server pointing to the right ip… just like you have done for your other domain/subdomain.

but its a sub domain of dev.new.citykites.com

@sachy123 being a sub domain doesn’t add automatically an ip for it :wink: you need to add an ip for all your subdomains.

But Last time, I didnt touch the A record for any subdomain… but I just used the certificates normally. I just did not write down these steps. I am not sure about how to add IP for all the sub domain too. :frowning:

I don’t know what you did nor how, but if you are using webroot method to issue a certificate you MUST have a CNAME pointing to another domain which resolves to an IP or an A record pointing to the ip of your web server.

These are your dns servers for zone dev.new.citykites.com

ns51.domaincontrol.com
ns52.domaincontrol.com

so you should have a control panel or similar in your registrar or hosting provider to add, delete or modify the host records of your domain.

1 Like

Yes I have the following A records right now in the zone of dev.new.citykites.com, what to add?

a 99anchors 160.153.71.135 1 Hour Edit
a @ 160.153.71.135 600 seconds Edit
a admin 160.153.71.135 600 seconds

Great, now 99anchors.dev.new.citykites.com has an ip but it redirects to www.99anchors.dev.new.citykites.com and there is no ip for this suddomain.

$ curl -IkL http://99anchors.dev.new.citykites.com
HTTP/1.1 301 Moved Permanently
Date: Sun, 10 Sep 2017 18:18:47 GMT
Server: Apache/2.4.25
Location: https://www.99anchors.dev.new.citykites.com/
Content-Type: text/html; charset=iso-8859-1

curl: (6) Couldn't resolve host 'www.99anchors.dev.new.citykites.com'

Cool… but what shall I do now?

What do you want to do?.

Do you want that the visitors that reach 99anchors.dev.new.citykites.com would be redirected to www.99anchors.dev.new.citykites.com? If you want that then of course you will also need an ip for www.99anchors (and issue a certificate for this subdomain too).

Keep in mind that you are now redirecting http://99anchors.dev.new.citykites.com to https://www.99anchors.dev.new.citykites.com which is an httpS site and don’t know if you have configured it properly.

Maybe your best approach now is to remove the redirection but I don’t know what you want to do.

Cheers,
sahsanu

It took me some while to understand first of all… but yes , 99anchors.dev.new has its own ip address. these are all subdomains of citykites.com

There was a redirection from 99anchors.com to https://www.99anchors.com
I removed the redirection… but it still gives me the same error!
I got the addon an domain of 99anchors.com on top of my host domain dev.new.citykites.com
root folder of addon domain is public_html/99anchors
and host domain is public_html

I dont know whats going on… why I am not able to certify the subdomain 99anchors.dev.new.citykites.com

There was and there is, the redirection is still there:

$ curl -IkL http://99anchors.com
HTTP/1.1 301 Moved Permanently
Date: Sat, 16 Sep 2017 16:50:04 GMT
Server: Apache/2.4.25
Location: https://www.99anchors.com/
Content-Type: text/html; charset=iso-8859-1

HTTP/1.1 200 OK
Date: Sat, 16 Sep 2017 16:50:04 GMT
Server: Apache/2.4.25
X-Powered-By: PHP/5.4.45
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: PHPSESSID=09ea0f66096cfbf089e1b04dc490f9e6; path=/
Vary: User-Agent
Content-Type: text/html

Again, you are also redirecting http://99anchors.dev.new.citykites.com to https://www.99anchors.dev.new.citykites.com but you have not defined an IP for www.99anchors.dev.new.citykites.com so nobody can reach this domain.

$ curl -IkL http://99anchors.dev.new.citykites.com
HTTP/1.1 301 Moved Permanently
Date: Sat, 16 Sep 2017 16:53:44 GMT
Server: Apache/2.4.25
Location: https://www.99anchors.dev.new.citykites.com/
Content-Type: text/html; charset=iso-8859-1

curl: (6) Could not resolve host: www.99anchors.dev.new.citykites.com

You domain 99anchors.dev.new.citykites.com resolves to ip 160.153.71.135

$ dig 99anchors.dev.new.citykites.com

; <<>> DiG 9.11.1 <<>> 99anchors.dev.new.citykites.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 804
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;99anchors.dev.new.citykites.com. IN    A

;; ANSWER SECTION:
99anchors.dev.new.citykites.com. 2301 IN A      160.153.71.135

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Sep 16 18:57:28 CEST 2017
;; MSG SIZE  rcvd: 65

but www.99anchors.dev.new.citykites.com doesn't resolve to an IP so there is no way to know how to reach it:

$ dig www.99anchors.dev.new.citykites.com

; <<>> DiG 9.11.1 <<>> www.99anchors.dev.new.citykites.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 17071
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.99anchors.dev.new.citykites.com. IN        A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Sep 16 18:59:20 CEST 2017
;; MSG SIZE  rcvd: 53

So, in summary:

1.- You have a Redirect/RewriteRule in your Apache conf, .htaccess file or WordPress, redirecting requests from http://yourdomains_without_ www to https://www.yourdomain.

2.- You have not created an A record in your DNS servers for domain www.99anchors.dev.new.citykites.com pointing to your server IP so, as you have the above redirection, it is impossible to reach your domain 99anchors.dev.new.citykites.com because it redirects to www.99anchors.dev.new.citykites.com.

Cheers,
sahsanu

1 Like

I can redirect 99anchors.dev.new.citykites.com
I am not able to find the A record for 99anchors.dev.new.citykites.com
26 PM
My .htaccess as below

Options +FollowSymLinks
IndexIgnore */*


<IfModule mod_rewrite.c>

RewriteEngine on

# ---------Start----------


RewriteCond %{HTTPS} off


# First rewrite to HTTPS:
# Don't put www. here. If it is already there it will be included, if not
# the subsequent rule will catch it.


RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


# Now, rewrite any request to the wrong domain to use www.

RewriteCond %{HTTP_HOST} ^99anchors.com/$ [NC]
RewriteRule ^(.*)$ https://www.99anchors.com/$1 [R=301,L] 






RewriteCond %{HTTP_USER_AGENT} libwww-perl.* 
RewriteRule .* – [F,L]



# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript



<IfModule mod_expires.c>
    ExpiresActive on
 
    ExpiresByType image/jpg "access plus 1 month"
    ExpiresByType image/jpeg "access plus 1 month"
    ExpiresByType image/gif "access plus 1 month"
    ExpiresByType image/png "access plus 1 month"
</IfModule>
# ---------End ----------


RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d



RewriteRule ^.*$ /index.php [L] 
</IfModule>

You don't need to redirect that domain.

Well, you already created it so... but anyway, you already have an A record for 99anchors.dev.new.citykites.com pointing to your server's ip 160.153.71.135 what you should do now, is create an A record for subdomain www.99anchors.dev.new.citykites.com pointing to ip 160.153.71.135. If you don't know how to create it, check GoDaddy's help or open a ticket to their support, anyway, here is the doc Create a subdomain | Domains - GoDaddy Help US

Regarding the RewrireRules:

This Rewrite:

RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Is saying, no matter what is the host name requested, redirect it to https://www.domainrequested/uri_requested.

Examples:

A request to http://99anchors.dev.new.citykites.com/index.php will be redirected to https://www.99anchors.dev.new.citykites.com/index.php and remember, as www.99anchors.dev.new.citykites.com has no IP assigned it is imposible to reach your server using that domain.

A request to http://www.99anchors.dev.new.citykites.com/index.php will be redirected to https://www.www.99anchors.dev.new.citykites.com/index.php which is really bad.

A request to http://99anchors.com/index.php will be redirected to https://www.99anchors.com/index.php.

Regarding these rules:

RewriteCond %{HTTP_HOST} ^99anchors.com/$ [NC]
RewriteRule ^(.*)$ https://www.99anchors.com/$1 [R=301,L]

They won't be used... never because HTTP_HOST never will have a trailing slash ^99anchors.com/$

That rule should be:

RewriteCond %{HTTP_HOST} ^99anchors.com$ [NC]
RewriteRule ^(.*)$ https://www.99anchors.com/$1 [R=301,L]

Anyway, your previous rule is already redirecting all domains to https://www.domains.

Please, if you want to use domain www.99anchors.dev.new.citykites.com add an ip to its A record. If you don't want to use that domain, remove the rewriterule.

RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Also, if you explain how you want to redirect your domains we could help to create the appropiate rules. I mean, you should say when the user try to access http://99anchors.dev.new.citykites.com it should be redirected to https://99anchors.dev.new.citykites.com or maybe to https://99anchors.com or https://www.99anchors.com... whatever.

Cheers,
sahsanu

2 Likes

I am trying to create an A record for subdomain www.99anchors.dev.new.citykites.com pointing to ip 160.153.71.135.

I am really not sure whats wrong and why I am not able to find the subdomain…

The host domain is dev.new.citykites.com

I added an Addon domain 99anchors.com and automatically , a subdomain was created as 99anchors.dev.new.citykites.com

I was able to write the A record in 99anchors.com to redirect to the ip address of the host domain (dev.new.citykites.com)

but no idea how www.99anchors.dev.new.citykites.com was created… :frowning: