Getting configured with https://gethttpsforfree.com on Shared Hosting


#1

Please fill out the fields below so we can help you better.

My domain is: www.aaimaa.in

I ran this command: I had followed various platforms, but No helped due to Not proper root access at Shared Hosting (Hostgator India). Almost finished at https://gethttpsforfree.com But not able to complete “Verify Ownership” with File-Based.

It produced this output: While creating the “.well-known/acme-challenge/” directory at my webserver’s static file path, i.e. /home/username/public_html/ everything was fine, created file. But, Now what next?
I means, where to put these, In .htaccess file at same directory or where?

These are the commands :
#apache example
Alias /.well-known/acme-challenge /path/to/www/.well-known/acme-challenge

while, My web server path is /path/to/home/username/public_html/.acme-challenege

and What actually “necessary contents” on step : 4.

Create the file with the necessary contents:
echo -n "fqM4QAYTchb6PMafW5MV4VQPHkYdRh-X9VcYXgUhXmw.ZA7sc3VEzn1-QM3EZ19x9QBzVmc1uLWX54bw9JPLQfs" > /path/to/www/.well-known/acme-challenge/fqM4QAYTchb6PMafW5MV4VQPHkYdRh-X9VcYXgUhXmw

My operating system is (include version): Debian Linux

My web server is (include version): cPanel, Multi-domain Hosting, With Network Privilege too(I’m using it for my WordPress website, more info at : HostGator India (Baby Plan)

My hosting provider, if applicable, is: HostGator India

I can login to a root shell on my machine (yes or no, or I don’t know): Yes, I have SSH access.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel


#2

What version of cpanel - it may be easier to chat to your host and ask them about the latest stable version of cpanel, which has Let’s Encypted integrated with it - so you could get a cert directly from cpanel.

The file needs to go in /home/username/public_html/.well-known/acme-challenge/

if you have SSH access on a shared cpanel server, you will SSH into /home/username so

cd public_html

to move into the public_html directory

mkdir -p .well-known/acme-challenge

to create the required directory

echo -n “fqM4QAYTchb6PMafW5MV4VQPHkYdRh-X9VcYXgUhXmw.ZA7sc3VEzn1-QM3EZ19x9QBzVmc1uLWX54bw9JPLQfs” > .well-known/acme-challenge/fqM4QAYTchb6PMafW5MV4VQPHkYdRh-X9VcYXgUhXmw


#3

cPanel version I’m having in shared Hosting(Hostgator) is : 54.0.28

As I seen your reply, I talked with support executive, they just said, mail this to our administrator. Managing Director will decide it whether to update or not. So, I just have only one option, Community help only.

@serverco I had done to create that directory and also done with echo command and successfully done. Everything is fine except redirecting .

As mentioned above in question and there at “https://gethttpsforfree.com/”, how to do this link for “Add the static folder to your webserver’s config (if you haven’t already)”. So, I’m having Apache Server. (SSL Rediection : image attached)

#apache example
Alias /.well-known/acme-challenge /path/to/www/.well-known/acme-challenge

So, exactly issue is this remains only for now. One more thing should be considered. In cPanel, while using “Softaculous” for easy installing WordPress. I had selected protocol there only http://www.aaimaa.in as displayed in screenshot-1.

One more Question here, I had not installed files in aaimaa.in root folder. I had selected “wp” folder to install files.

So, My concern was that, It is not necessary to install separate (as screenshot-2) from http:// with https://www.aaimaa.in/ for getting verified domain at https://gethttpsforfree.com/.

Attachment are here :

Screenshot-1
Screenshot-2
SSL Redirection Image

Hope you got my issue, situation and query as well. Thanking you a lot for contributing.


#4

You need version 58 of cpanel before it includes Let’s Encrypt - https://blog.cpanel.com/announcing-cpanel-whms-official-lets-encrypt-with-autossl-plugin/

how to do this link for “Add the static folder to your webserver’s config (if you haven’t already)”

You don’t need to do that. Simply upload the file, so that it can be displayed when you go to http://www.aaimaa.in/.well-known/acme-challenge/fqM4QAYTchb6PMafW5MV4VQPHkYdRh-X9VcYXgUhXmw in your browser.

Since you have all your wordpress in /wp/ you may already have redirects in place … generally though uploading to public_html/.well-known/acme-challenge should work.

You can test by uploading a simple text file into public_html/well-known/acme-challenge/test and checking you can reach it in the browser at http://www.aaimaa.in/.well-known/acme-challenge/test


#5

@serverco Yes!! When I created a simple txt file path (http://www.aaimaa.in/.well-known/acme-challenge/test.txt) are also reaching. It’s 404 Error Not Found error.

Any suggestion dear? I’m also continuously researching, I got somewhere, that In directory, /.well-known/acme-challenge/ , Should add .htaccess file to redirect this to https://www .

I just not had completed the 3rd step, that adding path in .htaccess. Is this not an issue ??

#apache example
Alias /.well-known/acme-challenge /path/to/www/.well-known/acme-challenge

#6

All this is saying is “if someone goes to /.well-known/acme-challenge then use the file from /path/to/www/.well-known/acme-challenge” … if you are placing the file in /.well-known/acme-challenge then you don’t need any alias.

Should add .htaccess file to redirect this to https://www

Again, this is not required. LE simply wants to obtain a file from domain/.well-known/acme-challenge/token

what is in your main .htaccess file ?


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.