Fritzbox 7590 Firmware 7.50 Update creashed certbot

Hi all,

today morning i run the firmware update on my fritzbox 7590 to version 7.50. After that all of my certs in my apache config recognized as self-signed and nothing works anymore for all of my sub domains.

Then i try to setup a new site (see below) but this also failed with the certbot message:

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Type: connection
Detail: 2003:c0:c7ff:27a3:de15:c8ff:fe5c:6cc4: Fetching Error getting validation data

After this i set my Linux server who hold all sites as "exposed host" in my fritzbox conf for looking if firtzbox firewall related but the same error appears.

Any hints?
Thanks a lot!


Hi @ralfi1, and welcome to the LE community forum :slight_smile:

Your question seems more suited for a Fritzbox support channel.
But since you're here...
Are these IPs correct?:

Addresses: 2003:c0:c728:f100:1049:2aec:6e3e:267b

The problem seems IPv6 related:

curl -Ii4
HTTP/1.1 200 OK
Date: Mon, 19 Dec 2022 10:46:10 GMT
Server: Apache
Last-Modified: Tue, 09 Nov 2021 10:19:11 GMT
ETag: "4a-5d05870d0f725"
Accept-Ranges: bytes
Content-Length: 74
Vary: Accept-Encoding
Content-Type: text/html

curl -Ii6
curl: (56) Recv failure: Connection reset by peer

Thanks a lot for reply,

your hint let me go the right way, two causes:

  • automatic recognation of changed ip addresses from dyn dns provider fails, could be related to fb firmware settings?
  • related to this dns failed

everything works now.
BTW, thanks for the warm welcome...


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.