[FIXED] Acme.sh --renew fail Verify error:Invalid response 403 Forbidden

Hello,

My domain is: cloud.clic2000.fr

I ran this command:

# acme.sh --renew --test -d cloud.clic2000.fr --debug 2 --insecure

It produced this output: https://paste.clic2000.net/7bfa5f

My web server is (include version):

$ sudo nginx -v
nginx version: nginx/1.17.1

The operating system my web server runs on is (include version):

$ sudo cat /etc/issue.net 
Debian GNU/Linux 9

My hosting provider, if applicable, is: Hetzner GmbH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

 # acme.sh --version
https://github.com/Neilpang/acme.sh
v2.8.2

FYI:

Thanks in advance!

I tried to delete the vhost and then re-issue the certificates for the domain mentioned, it worked!

So I think there is definitely a problem with my Nginx configuration and the vhost, can someone look at it? Here is the link to it: https://paste.clic2000.net/8817a1

Found it!

The http > https redirection caused this, I put it inside a location / and it works now.

    # Let's Encrypt webroot
    include includes/letsencrypt-webroot;

    # Redirect all HTTP requests to HTTPS with a 301 Moved Permanently response.
    location / {
        return 301 https://$host$request_uri;
    }
3 Likes