Firefox: The page isn't redirectly properly

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

tried to access website. Access worked with non-ssl. I installed such that certbot installed the contents /etc/letsencrypt and added ssl conf file in /etc/httpd/conf.d

It produced this output:

Firefox gives: The page isn’t redirecting propery

My web server is (include version):


The operating system my web server runs on is (include version):
Kernel: Linux 4.18.0.-240.22.1.el8_3.x86_64

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):


I'm using a control panel to manage my site (no, or provide the name and version of the control panel):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 1.14.0

Hi @Graphics3D

you have a loop - see

Domainname Http-Status redirect Sec. G 301 Html is minified: 100,00 % 0.266 A 301 Html is minified: 100,00 % 0.040 A 301 Html is minified: 109,46 % 2.390 F 301 Html is minified: 109,46 % 2.230 F

http redirects to https, that's ok.

But https redirects to http, that's always wrong.

Check your port 443 vHost definitions to remove that redirect.

Continuing the discussion from Firefox: The page isn't redirectly properly:

I have checked the configuration file and I don't see a problem. The conf file is below. Thanks for a quick response.

A .htaccess could also be responsible.

Then it's the wrong place.

Please check your complete configuration.

There answers a

Server: Sucuri/Cloudproxy

not an Apache. May be you have a WordPress or something else that redirects https -> http.

There is no .htaccess. It's a simple all html web page (literally 1 page). Thanks for the response.

When I revert to the non-ssl version I can see the site which is where I'm at now (conf file below). What I mean by non-ssl version is removing any attempt to use redirect or use the rewrite code from certbot (I'm not using both rewrite and redirect). I'm using the Centos 8 distribution version of apache so there's no configuration to be done other than creating the site specific configuration file which is below.

I forgot to mention that the site is a simple a one page website using only html and some javascript (for godaddy's secure site badge -- virus checker)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.