Failed to connect to -x-x-x-x-443 for tlssni-01 challenge


#1

Como puedo solucionar esto, Tengo ubuntu 16.4. Los puertos no estan bloqueados
IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.comunidadelrey.org.ve
    Type: connection
    Detail: Failed to connect to 31.170.166.96:443 for TLS-SNI-01
    challenge

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.


#2

Can you provide what command you were running ?

I can’t reach https://www.comunidadelrey.org.ve it just times out. Can you reach it ?


#3

Hola @Moralex74, ¿puede entender las preguntas de @serverco en Inglés más arriba?


#4

No he podido instalar el certificado
el comando que uso es:
./letsencrypt-auto --apache

luego coloco la direccion web, ejecuta pero me sale el error
Failed to connect to -x-x-x-x-443 for tlssni-01 challenge


#5

@Moralex74, no tenemos la costumbre de usar idiomas distintos del Inglés en este foro, pero no sé en que medida molestará a otros usuarios.

¿Ya tiene Apache instalado y activo en este servidor, y ya hay sitios disponibles en HTTP?


#6

Más dos cosas:

Un colega sugiere actualizar su cliente Certbot, tal vez instalándolo de nuevo (porque “letsencrypt-auto” es el nombre antigo del cliente y versiones más actuales se llamarían “certbot-auto”).

Él dice también que nmap detecta un firewall posible en este dirección IP, porque dice que puerto 443 está “filtrado”, no “cerrado”. Es difícil saber, pero hay la posibilidad de bloqueamento de puertos, tal vez en otro dispositivo o otra parte de la red y tal vez no en su proprio servidor.

Si tiene aceso a otra máquina fuera de la red del servidor, una opción sería ejecutar

echo Funciona | nc -l 443

en el servidor (como root), y

nc www.comunidadelrey.org.ve 443

en la otra máquina (en otra red), para ver si aparece (o no) el texto “Funciona” del otro lado.


#7

Gracia ya logre conseguirlo utilizando el comando siguiente:

iptables -nL | grep 443
netstat -nl | grep 443

./letsencrypt-auto certonly -a manual -d

dominio.com -d www.dominio.com --server
https://acme-v01.api.letsencrypt.org/directory --agree-dev-preview

Solo tuve que acceder a mi cpanel en File manager e introducir los archivos que se generaron durante el proceso en la carpeta
http://dominio.com/.well-known/acme-challenge/

Gracias por su ayuda


#8

for cpanel, please see https://blog.cpanel.com/announcing-cpanel-whms-official-lets-encrypt-with-autossl-plugin/ which works automatically and you don’t need to copy and paste the certificates.

Sorry, my written Spanish isn’t good enough to reply in your language.


#9

@Moralex74, es bueno saber que logró, pero el uso de -a manual puede ser irritante al punto de renovación del certificado (sólo duran 3 meses). A cada renovación, ¡tendrá que repetir los mismos pasos!

Otras opciones tal vez más prácticos serían el soporte oficial en cPanel que @serverco mencionó, o el plugin webroot que hace la autenticación criando los mismos archivos en /.well-known/acme-challenge para que usted no tenga que hacerlo.


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.