Failed authorization procedure Invalid response from

My domain

I ran this command: ./letsencrypt-auto certonly --webroot -w /web/xia/book/public_html/ --email -d -d -d --agree-tos

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
http-01 challenge for
http-01 challenge for
Using the webroot path /web/xia/book/public_html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from "<!doctype html>

<meta name="viewport""


My web server is (include version):nginx1.12

The operating system my web server runs on is (include version):Centos 7

I try to create a file test,
it worked!

Hi @henryyexm,

It works for and but not for, seems is not using the same webroot path /web/xia/book/public_html/ like the other sites so you should specify the right webroot path for this site in your command:

./letsencrypt-auto certonly --webroot -w /web/xia/book/public_html/ -d -d -w /webroot/path/to/m/ -d --agree-tos --email


You are right,I make a mistake ,Thanks a lot !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.