Exception Request

Dear Team,

Due to the recent changes to domain validation, we cannot renew domains any more. Our verification is based on HTTP challenge. Our domains are protected by firewall therefore not possible to renew it due to this. Certificates are expiring at Apr 1st 2020

I have filled out the form to have an exception list couple of days ago, https://docs.google.com/forms/d/e/1FAIpQLSfaW8KUOulxuf14bb5qsy0p30N83diZNYIpPD7OMFgT084hQg/viewform

Can you please whitelist my ID so that we can renew the certificates now?

My domain is: https://cms.techdoc.wl.boardconnect.aero/

I ran this command:
/opt/letsencrypt/letsencrypt-auto certonly --agree-tos --text --webroot -w /usr/share/nginx/html/ -d https://cms.techdoc.wl.boardconnect.aero/

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Cert is due for renewal, auto-renewing…
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for cms.techdoc.wl.boardconnect.aero
Using the webroot path /usr/share/nginx/html for all unmatched domains.
Waiting for verification…
Challenge failed for domain cms.techdoc.wl.boardconnect.aero
http-01 challenge for cms.techdoc.wl.boardconnect.aero
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cms.techdoc.wl.boardconnect.aero
    Type: connection
    Detail: During secondary validation: Fetching
    http://cms.techdoc.wl.boardconnect.aero/.well-known/acme-challenge/UASoYYCqbfuI1MCalCNOEUUS9lqijs9VNIcEFtmq6V4:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 1.3.0

You are blocking some IPs that let’s encrypt uses to validate your domain. Stop blocking them.

Hi @9peppe,

Unfortunately our services are firewall protected and should only be allowed to list know IP’s only.

Do you know what IP does L.E uses for validation?

The IPs are unknown and can change at any moment.

If you can’t be publicly reachable from the internet you need to switch to dns-01 validation.

That’s why I opted for exception to allow cert renewal based on this information.
ACME v1/v2: Validating challenges from multiple network vantage points.
I have submitted for an exception for an exception using this form https://docs.google.com/forms/d/e/1FAIpQLSfaW8KUOulxuf14bb5qsy0p30N83diZNYIpPD7OMFgT084hQg/viewform.

Can you possibly approve that?

I don’t have any authority, however:

I understand that this exception, if granted, will end on June 1, 2020.

(you realize it’s two months, do you?)

Hi @rajan

you have to open your firewall if you want to use http validation.

It’s wrong to block ip addresses. If script kiddies can hack your server, everyone can hack your server.

And if someone really want to hack your server, it’s easy to get a not blocked ip address.

@9peppe
That I understand, 2 months will give enough time to work alternate measures
Do you know who can approve that exception request?

@JuergenAuer Well it’s a company policy.

Then it’s your job to change that wrong company policy.

PS: Or

  • switch to dns validation
  • buy a certificate with mail validation.

That google form has put you in contact with the oracle, it will answer when it sees proper.

You have two options afaik – right now, and after June 1st:

  • allow traffic from ANY to port 80 on your machine;
  • switch to dns-01.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.