'/etc/letsencrypt/live/prod2.femtotest.com/fullchain.pem' does not exist or is empty

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: prod2.femtotest.com

I ran this command: sudo apache2ctl configtest

It produced this output:

[Wed Jul 03 11:03:06.003921 2019] [so:warn] [pid 121800:tid 140290606566336] AH01574: module wsgi_module is already loaded, skipping
AH00526: Syntax error on line 117 of /etc/apache2/sites-enabled/prod2.femtotest.com.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/prod2.femtotest.com/fullchain.pem’ does not exist or is empty
Action ‘configtest’ failed.
The Apache error log may have more information.

My web server is (include version): apache 2.4.29

The operating system my web server runs on is (include version): ubuntu 18.04

My hosting provider, if applicable, is: not applicable

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

I know this topic comes up a lot. My impression from the other answers is that it has to do with a chicken and egg thing - like it needs apache to standup to do the test, but for apache to standup it needs that /etc/letsencrypt/live directory with all its stuff like fullchain.pem which doesn’t exist. So Im not sure how to get out of this state. I have seen people metion deleting certain conf files but nothing has worked so far for me. Any help would be much appreciated

Hi @alexyz

looks like you have deleted or moved that file or the resulting file (live contains symlinks).

One simple option. Deactivate that site with a2dissite.

Or create a self signed certificate and use that temporary.

No. It’s only a problem if a used certificate is deleted. That’s always bad.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.