Error with phpMyAdmin after Certbot created certificate on Ubuntu

Everything seems to work but this error message keeps popping up:
OpenSSL error: error:0906D06C:PEM routines:PEM_read_bio:no start line
I saw a previous item from Mar '16 but those solutions all were OK.

Hi @dwwaddell,

What did you do to install your certificate after obtaining it with Certbot?

I did nothing; Certbot did it all and everything worked except this message from phpmyadmin. The only thing I did was to add a cron job to run every three months (this was a while after the install):

30 03 01 */3 1 certbot renew


So, did you see this error inside of a web page that’s loaded successfully over HTTPS, or on a console? In what context do you see it? Can you access HTTPS pages on your server in general?

Everything works perfectly as far as HTTPS connections. Strangely, the phpMyAdmin connects using HTTP:

Can you manually specify HTTPS instead of HTTP when connecting to it?

The original mail bounced so I removed the links in case that was the problem.


It shows:

localhost uses an invalid security certificate. The certificate is only valid for the following names:, Error code: SSL_ERROR_BAD_CERT_DOMAIN

However, when I add the exception, the HTTPS connection is made and there are no error messages.

Let’s Encrypt certificates aren’t valid for localhost. No publicly trusted certificate authority is allowed to issue certificates for localhost. If you need to connect via HTTPS to localhost, there are lots of options including what you already did (adding an exception), using a self-signed certificate for which you would also add an exception, or adding a localhost subdomain of an existing domain and getting a certificate for that name.

I probably should have thought of this before telling you to specify HTTPS for something that you were connecting to on a LAN.

But this doesn’t explain the OpenSSL error that you’re seeing…

Well, I take that back—once I exited the browser and came back in, the message came up again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.