Error when trying to secure my Nextcloud, no valid

The operating system my web server runs on is (include version): ubuntu 22.01.1

My hosting provider, if applicable, is: cloudflare

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no, use cloudflare

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.21.0

I'm trying to configure certbot for, but it gives me the error "no valid A records found for; no valid AAAA records found for". But this works.

Without the domain name I don't know what you think we can do.

The error message is pretty clear that the Let's Encrypt Server cannot find an A or AAAA record for IPv4 or IPv6, respectively. At least one is required for the HTTP Challenge you requested (via Apache authenticator).

You should review your DNS configuration. The Let's Debug test site is often helpful when setting up a new site.


Hello @alexciuc,

Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.


Hi @alexciuc, and welcome to the LE community forum :slight_smile:

You must have a working HTTP site before you can secure it using HTTP-01 authentication.


See also

to learn about how Let's Encrypt can validate your control over domain names.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.