Error to many request


#1

totally new at this
when trying to set up certificate with lighttpd
i get this error :ERROR:certbot.log:There were too many requests of a given type

i am using me.foo.com where foo.com is from freedns .

is it possible to do this ?


#2

Hi @mijo

what type? There is a list of questions you should answer:

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

using raspbian stretch
webserver is lighttpd/1.4.45

i use both method when running /etc/lighttpd/ssl/certbot-auto certonly from shell
for domain i put
as i said output of this was
Error: urn:ietf:params:acme:error:rateLimited :: There were too many requests of a given type

too many certificates already issued for: sub.mooo.com -sub modified for privacy
i understand the error but most likely this will be for any domain from
https://freedns.afraid.org/


#4

Please see

Free DNS providers can get around this problem by listing their domains with the Public Suffix List and/or requesting an exemption directly from Let’s Encrypt. If they don’t do this, there is nothing that an end user can do except watch the issuance history closely and try again frequently, or switch to a different domain.

When choosing a free DNS provider and domain, you may want to check whether the domain currently has a Let’s Encrypt rate limit exemption.


#5

but thats not something i have control.
so how would i overcome this


#6

It’s not something that we have control over either. These rate limits are automatically enforced by software.

The only options are to change domains, or get the provider to take the rate limit exemption steps, or rely on luck, persistence, or planning to get ahead of other users to obtain a certificate.


#7

If you want to use another domain, perhaps you can get one from

https://www.freenom.com/

Free subdomains have always the problem, if they are not in the

https://publicsuffix.org/list/public_suffix_list.dat


#8

According to https://github.com/publicsuffix/list/issues/271 , about the inclusion in the PSL:

I talked to the owner and admin of afraid.org. He mentioned but there’s a automated list of all domain hosted on afraid.org that are public 1 but he is not interested in helping any further.


#9

50 a week
week COUNTER starts sunday or monday ?


#10

It’s a 7 days sliding window.

If you’ve hit a rate limit, we don’t have a way to temporarily reset it. You’ll need to wait until the rate limit expires after a week. We use a sliding window, so if you issued 25 certificates on Monday and 25 more certificates on Friday, you’ll be able to issue again starting Monday.


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.