Error: should only be one vhost with apache but only one vhost configured?


#1

Hi guys,

I did find several posts about the same issue but did not find any solution and tried already all I can imagine.
My httpd.conf contain only one vhost entry which looks like this


ServerName xxxxxxxx.com ServerAlias www.xxxxxxxx.com DocumentRoot /home/paula01/public_html ServerAdmin sys-admin@xxxxxxx.com ErrorLog /home/paula01/logs/error_log_dbserver.txt #CustomLog /home/paula01/logs/access_log combined DirectoryIndex index.php index.html index.htm
    ErrorDocument 500       /pages.php/PT/000/ops.php?code=500
    ErrorDocument 404       /pages.php/PT/000/ops.php?code=404
    ErrorDocument 403       /pages.php/PT/000/ops.php?code=403
    ErrorDocument 401       /pages.php/PT/000/ops.php?code=401
    ErrorDocument 400       /pages.php/PT/000/ops.php?code=400

    <Directory "/home/paula01/public_html">
            Options FollowSymLinks
            AllowOverride all
            Order allow,deny
            Allow from all
    </Directory>
    <Location "/dynamic">
            ForceType application/x-httpd-php
    </Location>

I do not have any vhosts in my /sites/ directory configured as well.
I tried already all I can think of, the cert creation works but I get always the error “Error: should only be one vhost in /etc/httpd/conf/httpd.conf”

what can I do? is there maybe a way to install the certificate manually for me apache?

thanks in advance for your help…


#2

A little bit after my first post I found the topic "one vhost per file"

and this is exactly what was my problem. I took the vhost part out of my main httpd.conf and moved to a seperated files in /sites. Once done the automatic apache configuration and cert creation worked perfect.

thx.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.