Error renew from Windows Certes

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: myAccount = Await myAcme.NewAccount(myEmail, True)

It produced this output: : Fail to load resource from ''.
urn:ietf:params:acme:error:serverInternal: failed check for existing account - at Certes.Acme.IAcmeHttpClientExtensions

My web server is (include version): IIS 10

The operating system my web server runs on is (include version): Windows 2019 (1809)

My hosting provider, if applicable, is: Me

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Certes 3.0.3

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hello, I use .NET based program to renew our certificates. It worked well for many months. Last 2 months running from scheduler falls into error:
Fail to load resource from ''.
urn:ietf:params:acme:error:serverInternal: failed check for existing account - at Certes.Acme.IAcmeHttpClientExtensions.

When I run it pressing button Run on the task in task scheduler, it works well.

Any help appreciated.
Thank you very much

1 Like

Welcome to the community @mmsw

I have no experience with your config so cannot help. From the error it does not remind me of any problem in Let's Encrypt. Sounds more like a Windows authentication issue or problem in Certes config. But, I could easily be wrong.

I am posting to recommend also asking about this on the github for Certes. There are more experts there with your specific config and a quicker response may be possible.


If it runs as a task but not as your own user then perhaps check your proxy configuration (have you used Fiddler etc on that machine?). Also do a basic check using a web browser on the same machine to ensure you can access


Hello, thank you very much.
I will ask Certes forum.


there is no proxy set on my server.
My utility is .NET program, that is used by Task Scheduler.

  1. If it is run by Task Sheduler timer, it returns error.
  2. If I run it manualy by Run button in Task Scheduler, it works well.
    I cannot find any difference. Same user, same rights (highest privilege).
    Server has access to letsencrypt page by Chrome.

Not likely.
Make sure the task is run with the same credentials and starts in the right path/path/location.


it is the same task. So it should have same credentials and path.

On the general tab of the task, is it selected with "Run whether user is logged on or not" ?


Yes, it is.

Show the "Actions" tab.


Edit that action and set it to start in that location ("c:\mmsw\IISadmin").


It is set that way:

1 Like

Then I don't understand why this can ever fail to run.

Maybe the password for that user has been changed since this task was created ? ? ?


I also don't understand.
I am sure that password was not changed.
It would be fail by Run button too.

Thank you for your help.

I'm not so sure...
"Allow the task to be run on demand" should use the current user creds.
[which might have a different password now]


You are right. I will check it out.

I don't know more and more.
Running from cmd RUNAS with same user as in scheduler was without error.

Reset the user and password in the task.
Then see if that works.


I will do it and let you know.
I will also try another user.
I don't think error is related to user account.
The error comes from Certes package, that is used in program.