ERROR - Please help - Redcastle Hosting


#1

Hello im lars from redcastlehosting and got an error this is the information of the error

My domain is: paneel.redcastlekd.tk

I ran this command: letsencrypt certonly

It produced this output: An unexpected error occurred:
TypeError: unicode() argument 2 must be string, not None
Please see the logfiles in /var/log/letsencrypt for more details.

logfile: 2016-08-29 14:06:39,425:DEBUG:certbot.main:Root logging level set at 30
2016-08-29 14:06:39,426:INFO:certbot.main:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2016-08-29 14:06:39,427:DEBUG:certbot.main:certbot version: 0.8.1
2016-08-29 14:06:39,427:DEBUG:certbot.main:Arguments: [’–standalone’, ‘-d’, ‘paneel.redcastlekd.tk’]
2016-08-29 14:06:39,427:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#webroot,PluginEntryPoint#null,PluginEntryPoint#manual,PluginEntryPoint#standalone)
2016-08-29 14:06:39,431:DEBUG:certbot.plugins.selection:Requested authenticator standalone and installer None
2016-08-29 14:06:39,517:DEBUG:certbot.plugins.selection:Single candidate plugin: * standalone
Description: Automatically use a temporary webserver
Interfaces: IAuthenticator, IPlugin
Entry point: standalone = certbot.plugins.standalone:Authenticator
Initialized: <certbot.plugins.standalone.Authenticator object at 0x7fa578772550>
Prep: True
2016-08-29 14:06:39,518:DEBUG:certbot.plugins.selection:Selected authenticator <certbot.plugins.standalone.Authenticator object at 0x7fa578772550> and installer None
2016-08-29 14:06:39,689:DEBUG:certbot.main:Picked account: <Account(30f6daa6c65b9d79df3a797be3c09f95)>
2016-08-29 14:06:39,690:DEBUG:root:Sending GET request to https://acme-v01.api.letsencrypt.org/directory. args: (), kwargs: {}
2016-08-29 14:06:39,691:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
2016-08-29 14:06:39,926:DEBUG:requests.packages.urllib3.connectionpool:“GET /directory (‘HTTP/1.1’,)” 200 280
2016-08-29 14:06:39,927:DEBUG:root:Received <Response [200]>. Headers: {‘content-length’: ‘280’, ‘expires’: ‘Mon, 29 Aug 2016 14:06:39 GMT’, ‘boulder-request-id’: ‘bOnOqFoqAeZqCdLS_fMEEU8nQEr4PP7BvD-vFdqgB-o’, ‘strict-transport-security’: ‘max-age=604800’, ‘server’: ‘nginx’, ‘connection’: ‘keep-alive’, ‘pragma’: ‘no-cache’, ‘cache-control’: ‘max-age=0, no-cache, no-store’, ‘date’: ‘Mon, 29 Aug 2016 14:06:39 GMT’, ‘x-frame-options’: ‘DENY’, ‘content-type’: ‘application/json’, ‘replay-nonce’: ‘Xyys-YJu9z2y8sobQuzJjf7nLRbD1YQNYy5b5YgJVNs’}. Content: '{\n “new-authz”: “https://acme-v01.api.letsencrypt.org/acme/new-authz”,\n “new-cert”: “https://acme-v01.api.letsencrypt.org/acme/new-cert”,\n “new-reg”: “https://acme-v01.api.letsencrypt.org/acme/new-reg”,\n “revoke-cert”: “https://acme-v01.api.letsencrypt.org/acme/revoke-cert”\n}'
2016-08-29 14:06:39,927:DEBUG:acme.client:Received response <Response [200]> (headers: {‘content-length’: ‘280’, ‘expires’: ‘Mon, 29 Aug 2016 14:06:39 GMT’, ‘boulder-request-id’: ‘bOnOqFoqAeZqCdLS_fMEEU8nQEr4PP7BvD-vFdqgB-o’, ‘strict-transport-security’: ‘max-age=604800’, ‘server’: ‘nginx’, ‘connection’: ‘keep-alive’, ‘pragma’: ‘no-cache’, ‘cache-control’: ‘max-age=0, no-cache, no-store’, ‘date’: ‘Mon, 29 Aug 2016 14:06:39 GMT’, ‘x-frame-options’: ‘DENY’, ‘content-type’: ‘application/json’, ‘replay-nonce’: ‘Xyys-YJu9z2y8sobQuzJjf7nLRbD1YQNYy5b5YgJVNs’}): '{\n “new-authz”: “https://acme-v01.api.letsencrypt.org/acme/new-authz”,\n “new-cert”: “https://acme-v01.api.letsencrypt.org/acme/new-cert”,\n “new-reg”: “https://acme-v01.api.letsencrypt.org/acme/new-reg”,\n “revoke-cert”: “https://acme-v01.api.letsencrypt.org/acme/revoke-cert”\n}'
2016-08-29 14:06:39,929:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
File “/usr/bin/letsencrypt”, line 9, in
load_entry_point(‘certbot==0.8.1’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python2.7/dist-packages/certbot/main.py”, line 744, in main
return config.func(config, plugins)
File “/usr/lib/python2.7/dist-packages/certbot/main.py”, line 550, in obtain_cert
le_client = _init_le_client(config, auth, installer)
File “/usr/lib/python2.7/dist-packages/certbot/main.py”, line 367, in _init_le_client
return client.Client(config, acc, authenticator, installer, acme=acme)
File “/usr/lib/python2.7/dist-packages/certbot/client.py”, line 184, in init
acme = acme_from_config_key(config, self.account.key)
File “/usr/lib/python2.7/dist-packages/certbot/client.py”, line 42, in acme_from_config_key
return acme_client.Client(config.server, key=key, net=net)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 63, in init
self.net.get(directory).json())
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 631, in get
self._send_request(‘GET’, url, **kwargs), content_type=content_type)
File “/usr/lib/python2.7/dist-packages/acme/client.py”, line 561, in _check_response
jobj = response.json()
File “/usr/lib/python2.7/dist-packages/requests/models.py”, line 845, in json
return json.loads(self.text or self.content)
File “/usr/lib/python2.7/dist-packages/requests/models.py”, line 831, in text
content = str(self.content, encoding, errors=‘replace’)
TypeError: unicode() argument 2 must be string, not None

My operating system is (include version): debian 8 jessie

My web server is (include version): nignx newest version

My hosting provider, if applicable, is: ovh

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): IDK

- lars jarred l Redcastle Hosting


#2

somone ??? please help…


#3

i fixed it myself :)))))))))))))))))))


#4

Maybe it’s a good idea to say how you fixed it…


#5

i downloaded phyton and it worked.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.